aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-bsp
diff options
context:
space:
mode:
authorDuy Dang <duy.dang.yw@rvc.renesas.com>2018-10-17 18:26:04 +0700
committerDuy Dang <duy.dang.yw@rvc.renesas.com>2018-10-19 10:36:41 +0700
commitd71480635ff07cfa48bbbd684c15a09fabb093b3 (patch)
tree9219bc2db0fef60fdade92ad46917920eff589af /meta-rcar-gen3/recipes-bsp
parent5fe2bafb3bf963ab3027be1e4d93c1281b9dd6a2 (diff)
rcar-gen3: OP-TEE: Apply fix patch
This commit applies a patch to fix the following issues: - Fix to set the initial value for a parameter in TEE_AEInit - Fix to clear the read cache of standalone_fs_create. Signed-off-by: Duy Dang <duy.dang.yw@rvc.renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
Diffstat (limited to 'meta-rcar-gen3/recipes-bsp')
-rw-r--r--meta-rcar-gen3/recipes-bsp/optee/optee-os/0001-Update-optee_os-Rev1.0.16-rev2.patch42
-rw-r--r--meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb1
2 files changed, 43 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-bsp/optee/optee-os/0001-Update-optee_os-Rev1.0.16-rev2.patch b/meta-rcar-gen3/recipes-bsp/optee/optee-os/0001-Update-optee_os-Rev1.0.16-rev2.patch
new file mode 100644
index 0000000..6265cfc
--- /dev/null
+++ b/meta-rcar-gen3/recipes-bsp/optee/optee-os/0001-Update-optee_os-Rev1.0.16-rev2.patch
@@ -0,0 +1,42 @@
+From 35f6b872b7bd4cd0245f4c8b2e4a2cdc86fe8151 Mon Sep 17 00:00:00 2001
+From: Takuya Sakata <takuya.sakata.wz@bp.renesas.com>
+Date: Tue, 16 Oct 2018 15:31:31 +0900
+Subject: [PATCH] Update optee_os Rev1.0.16 rev2
+
+ - Fix to set the initial value for a parameter in TEE_AEInit.
+ - Fix to clear the read cache of standalone_fs_create.
+---
+ core/arch/arm/plat-rcar/tee/tee_standalone_fs.c | 4 ++++
+ lib/libutee/tee_api_operations.c | 1 +
+ 2 files changed, 5 insertions(+)
+
+diff --git a/core/arch/arm/plat-rcar/tee/tee_standalone_fs.c b/core/arch/arm/plat-rcar/tee/tee_standalone_fs.c
+index c51b2cd..a475940 100644
+--- a/core/arch/arm/plat-rcar/tee/tee_standalone_fs.c
++++ b/core/arch/arm/plat-rcar/tee/tee_standalone_fs.c
+@@ -942,6 +942,10 @@ static void spi_write_record_data(struct spif_record_info *record_info,
+ }
+
+ record_info->record_head.data_len = dpos;
++
++ if (g_record_data_rdesc != NULL) {
++ g_record_data_rdesc = NULL;
++ }
+ }
+
+ static void spi_get_parent_dir(const char *path, size_t path_len,
+diff --git a/lib/libutee/tee_api_operations.c b/lib/libutee/tee_api_operations.c
+index 2b11fd2..036ec13 100644
+--- a/lib/libutee/tee_api_operations.c
++++ b/lib/libutee/tee_api_operations.c
+@@ -1343,6 +1343,7 @@ TEE_Result TEE_AEInit(TEE_OperationHandle operation, const void *nonce,
+ if (res != TEE_SUCCESS)
+ goto out;
+
++ operation->buffer_offs = 0U;
+ operation->ae_tag_len = tagLen / 8;
+ operation->info.handleState |= TEE_HANDLE_FLAG_INITIALIZED;
+
+--
+1.9.1
+
diff --git a/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb b/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
index 765e24d..98c8776 100644
--- a/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
+++ b/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
@@ -26,6 +26,7 @@ SRC_URI = " \
SRC_URI_append = " \
file://0001-OPTEE_PROVIDER-188185-Fix-a-contxt-size-allocated-by.patch \
file://0002-OPTEE_PROVIDER-188122-Fix-to-exclusive-control-for-R.patch \
+ file://0001-Update-optee_os-Rev1.0.16-rev2.patch \
"
COMPATIBLE_MACHINE = "(salvator-x|h3ulcb|m3ulcb|ebisu)"