aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-bsp
diff options
context:
space:
mode:
authorKhang Nguyen <khang.nguyen.xv@rvc.renesas.com>2018-02-22 14:17:14 +0700
committerKhang Nguyen <khang.nguyen.xv@rvc.renesas.com>2018-03-22 13:36:54 +0700
commite5d677b3c180c6568f13dd76ca8432eb42584f77 (patch)
treee53f155725a67270a696e795f8ba552232006e3f /meta-rcar-gen3/recipes-bsp
parent84106edc2e3d943dadf0800ca4e99b1bebb1c9e5 (diff)
rcar-gen3: IPL: Update IPL according to BSP v3.6.1 and add support E3
This commit changes following contents: - Update IPL and Secure Monitor Rev1.0.19. - Update optee_os Rev1.0.12. It also updates recipes to add support E3 board. Signed-off-by: Khang Nguyen <khang.nguyen.xv@rvc.renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
Diffstat (limited to 'meta-rcar-gen3/recipes-bsp')
-rw-r--r--meta-rcar-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb5
-rw-r--r--meta-rcar-gen3/recipes-bsp/optee/optee-client_git.bb2
-rw-r--r--meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb4
3 files changed, 6 insertions, 5 deletions
diff --git a/meta-rcar-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb b/meta-rcar-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb
index a088c2f..31c5849 100644
--- a/meta-rcar-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb
+++ b/meta-rcar-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb
@@ -12,16 +12,17 @@ S = "${WORKDIR}/git"
BRANCH = "rcar_gen3"
SRC_URI = "git://github.com/renesas-rcar/arm-trusted-firmware.git;branch=${BRANCH}"
-SRCREV = "b01e6aa3f22eaf4a769dc0be29ef69eb89911b60"
+SRCREV = "505f0c0a970e532c072aa523b514386e3796b82a"
PV = "v1.4+renesas+git${SRCPV}"
-COMPATIBLE_MACHINE = "(salvator-x|ulcb)"
+COMPATIBLE_MACHINE = "(salvator-x|ulcb|ebisu)"
PLATFORM = "rcar"
ATFW_OPT_LOSSY = "${@base_conditional("USE_MULTIMEDIA", "1", "RCAR_LOSSY_ENABLE=1", "", d)}"
ATFW_OPT_r8a7795 = "LSI=H3 RCAR_DRAM_SPLIT=1 ${ATFW_OPT_LOSSY}"
ATFW_OPT_r8a7796 = "LSI=M3 RCAR_DRAM_SPLIT=2 ${ATFW_OPT_LOSSY}"
ATFW_OPT_r8a77965 = "LSI=M3N ${ATFW_OPT_LOSSY}"
+ATFW_OPT_r8a77990 = "LSI=E3 RCAR_SA0_SIZE=0 RCAR_AVS_SETTING_ENABLE=0 ${ATFW_OPT_LOSSY}"
ATFW_OPT_append_ulcb = " RCAR_GEN3_ULCB=1 PMIC_LEVEL_MODE=0"
# requires CROSS_COMPILE set by hand as there is no configure script
diff --git a/meta-rcar-gen3/recipes-bsp/optee/optee-client_git.bb b/meta-rcar-gen3/recipes-bsp/optee/optee-client_git.bb
index 454f82b..4075532 100644
--- a/meta-rcar-gen3/recipes-bsp/optee/optee-client_git.bb
+++ b/meta-rcar-gen3/recipes-bsp/optee/optee-client_git.bb
@@ -16,7 +16,7 @@ SRC_URI += " \
inherit systemd
SYSTEMD_SERVICE_${PN} = "optee.service"
-COMPATIBLE_MACHINE = "salvator-x|h3ulcb|m3ulcb"
+COMPATIBLE_MACHINE = "salvator-x|h3ulcb|m3ulcb|ebisu"
PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb b/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
index 55eab8e..ee73de3 100644
--- a/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
+++ b/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
@@ -13,7 +13,7 @@ inherit deploy pythonnative
PV = "2.6.0+renesas+git${SRCPV}"
BRANCH = "rcar_gen3"
-SRCREV_renesas = "d1e9802d537b9fe8d1b7cace09254049b3dfca3f"
+SRCREV_renesas = "58147841a05b8a09aa92a8fae60b3207e4fe72bc"
SRCREV_officialgit = "6d57389f9eec0c213da917e35861a8eca4b205b3"
SRCREV_FORMAT = "renesas_officialgit"
@@ -22,7 +22,7 @@ SRC_URI = " \
git://github.com/OP-TEE/optee_os.git;branch=master;name=officialgit;destsuffix=git_official \
"
-COMPATIBLE_MACHINE = "(salvator-x|h3ulcb|m3ulcb)"
+COMPATIBLE_MACHINE = "(salvator-x|h3ulcb|m3ulcb|ebisu)"
PLATFORM = "rcar"
DEPENDS = "python-wand-native python-pycrypto-native"