aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-graphics/wayland
diff options
context:
space:
mode:
authorStephen Lawrence <stephen.lawrence@renesas.com>2017-01-04 20:37:08 +0000
committerKhiem Nguyen <khiem.nguyen.xt@renesas.com>2017-03-27 03:34:01 +0000
commit0f150a21d21bc7e24ea111d1e039abad76b4dfc0 (patch)
treee72353fe278b32d5dae08d53aed7ac8600ab42cd /meta-rcar-gen3/recipes-graphics/wayland
parentbad228d40fbec195d2ec0240e34606bcd08126cb (diff)
rcar-gen3: weston: Add support ivi-shell and ivi-extension
This commit configures weston to use the Genivi Compositor components ivi-shell and ivi-extension rather than the default desktop-shell. Default status is disabled. To enable ivi-shell and ivi-extension, please uncomment the following line in local.conf: DISTRO_FEATURES_append = " ivi-shell" Change-Id: Ia6aa51175c83bf4b9f3e887cd114b3755c1e4e09 Signed-off-by: Stephen Lawrence <stephen.lawrence@renesas.com> Signed-off-by: Thao Nguyen <thao.nguyen.yb@rvc.renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
Diffstat (limited to 'meta-rcar-gen3/recipes-graphics/wayland')
-rw-r--r--meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend17
1 files changed, 15 insertions, 2 deletions
diff --git a/meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend b/meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend
index 66dedfe..2047457 100644
--- a/meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend
+++ b/meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend
@@ -28,18 +28,31 @@ PACKAGECONFIG_append = " \
PACKAGECONFIG[v4l2] = " --enable-v4l2, --disable-v4l2,,kernel-module-vsp2driver"
do_install_append() {
+ install -d ${D}/${sysconfdir}/xdg/weston
if [ "X${USE_MULTIMEDIA}" = "X1" ]; then
# install weston.ini as sample settings of v4l2-renderer
- install -d ${D}/${sysconfdir}/xdg/weston
if [ "${MACHINE}" = "m3ulcb" -o "${MACHINE}" = "h3ulcb" ] ; then
sed -i 's|media1|media0|g' ${WORKDIR}/weston_v4l2.ini
fi
install -m 644 ${WORKDIR}/weston_v4l2.ini ${D}/${sysconfdir}/xdg/weston/weston.ini
else
# install weston.ini as sample settings of gl-renderer
- install -d ${D}/${sysconfdir}/xdg/weston
install -m 644 ${WORKDIR}/weston.ini ${D}/${sysconfdir}/xdg/weston/
fi
+
+ # Checking for ivi-shell configuration
+ # If ivi-shell is enable, we will add its configs to weston.ini
+ if [ "X${USE_WAYLAND_IVI_SHELL}" = "X1" ]; then
+ sed -i '/repaint-window=34/c\repaint-window=34\nshell=ivi-shell.so' \
+ ${D}/${sysconfdir}/xdg/weston/weston.ini
+ sed -e '$a\\' \
+ -e '$a\[ivi-shell]' \
+ -e '$a\ivi-module=ivi-controller.so' \
+ -e '$a\ivi-input-module=ivi-input-controller.so' \
+ -e '$a\transition-duration=300' \
+ -e '$a\cursor-theme=default' \
+ -i ${D}/${sysconfdir}/xdg/weston/weston.ini
+ fi
}
FILES_${PN}_append = " \