aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-graphics/wayland
diff options
context:
space:
mode:
authorThao Nguyen <thao.nguyen.yb@renesas.com>2017-07-15 18:34:21 +0700
committerThao Nguyen <thao.nguyen.yb@renesas.com>2017-08-25 08:45:32 +0700
commitf8e997803ce1f4af660bf527e8a47805af440baf (patch)
tree6522b7d0b98eb94b2b8a54e95f1b7b9234b80e0b /meta-rcar-gen3/recipes-graphics/wayland
parentbc0a99ebfbe6c14c7f94b298ca89ea5e02656e78 (diff)
rcar-gen3: libegl: Create new recipe to fix build dependency issues
This commit adds libegl recipe which provides build dependencies on virtual/egl. Signed-off-by: Thuy Tran <thuy.tran.xh@rvc.renesas.com> Signed-off-by: Thao Nguyen <thao.nguyen.yb@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
Diffstat (limited to 'meta-rcar-gen3/recipes-graphics/wayland')
-rw-r--r--meta-rcar-gen3/recipes-graphics/wayland/libegl.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-graphics/wayland/libegl.bb b/meta-rcar-gen3/recipes-graphics/wayland/libegl.bb
new file mode 100644
index 0000000..0bde4ae
--- /dev/null
+++ b/meta-rcar-gen3/recipes-graphics/wayland/libegl.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Recipe for libegl"
+LICENSE = "CLOSED"
+
+DEPENDS = "gles-user-module \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'libgbm wayland-kms', '', d)} \
+"
+
+PR = "r0"
+
+RDEPENDS_${PN} = " \
+ gles-user-module \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'libgbm wayland-kms', '', d)} \
+"
+
+PROVIDES = "virtual/egl"
+RPROVIDES_${PN} += " \
+ libegl \
+ libegl1 \
+"