aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
diff options
context:
space:
mode:
authorDuy Dang <duy.dang.yw@rvc.renesas.com>2018-10-20 14:55:18 +0700
committerDuy Dang <duy.dang.yw@rvc.renesas.com>2018-12-19 15:23:55 +0700
commit0814c5cebd418b10a24b11e22ae08a84324d0f27 (patch)
treeebbd74ba4f5601ce202f057abf19d0d99d4a48db /meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
parent98f4f5ec2c9bc4ab03d430e9cdcb4b7591a64dcd (diff)
rcar-gen3: linux-renesas: Upgrade Linux BSP to v3.9.2
This commit upgrades Linux BSP to v3.9.2 for the following changes: [Kernel] - Add support for RCKSEL clock selection. - Fix pin functions of R-Car E3 according to H/W UM Rev1.00 errata. - Fix warning of the make W=1 C=2. - Identify R-Car M3 Ver.1.3. - Add the big.LITTLE CAS scheduler fix patches. - Fix MOD_SEL bit numbering for R-Car E3. [Power Management] - Fixup power-domains of 3DGE for R-Car E3 Ver.1.0 and add device tree file for R-Car E3 Ver.1.0. [Audio Driver] - Fixup clock start checker. - Resolve the problem that the noise is generated during long playback with R-Car E3 Ebisu-4D board by kernel rebasing. [Display Driver] - Add function of suspend and resume to adv7511_drv.c and add hot plug event function at resume in rcar_du_drv.c. - Add depends on DRM_RCAR_DU to config DRM_RCAR_LVDS. - Revert "drm: rcar-du: Fix legacy DT to create LVDS encoder nodes". - Add clock function for LVDS PLL. [Ethernet Driver] - Decrease TxFIFO depth of Q3 and Q2 to one. - Fix not to call phy_resume() if PHY is not attached and add toggling phy reset if PHY is not attached. - Revert "ravb: RX checksum offload" for communicating of Q-Tag VLAN frame correctly. - Resolved the problem that the S2RAM resume failed on R-Car E3 Ebisu-4D by kernel rebasing. - Avoid unsupported internal delay mode for R-Car E3 and limit to 100Mbps. [I2C Driver] - Check bus state before reinitializing. [IPMMU Driver] - Fix crash on early domain free. - Revert "arm64: defconfig: Enable QCOM_IOMMU" for suspending with LTSI kernel. - Correct whitelist devices assignment. [PCIe Driver] - Avoid PCI device removing/rescanning through sysfs triggers a deadlock. [PWM Driver] - Avoid deadlock warning when removing PWM device. [SD/MMC Driver] - Fix card initialization failure in high speed mode. - Add adjust HS400 offset by manual calibration mode and adjust HS400 offset by manual calibration mode for R-Car M3 Ver.1.3. [USB2.0 Function] - Add reset_control. - Backport upstream patches to support OTG mode for R-Car E3. - Make DMAC system sleep callbacks explicit. - Add Super-Speed (b-device) support. [Video Capture driver] - Review adv748x driver for R-Car E3 Ebisu board and add option for changing SD output route to TXA. - Revert "rcar-vin: rcar-csi2: Add blank margin when caluculating bit rate" and fix pixel rate values. - Add CPG reset and release when using digital pin. [RWDT Driver] - Don't keep timer value during suspend/resume. - Don't set divider while watchdog is running. This also updates ADSP driver patches to adapt to the new Linux version. Signed-off-by: Duy Dang <duy.dang.yw@rvc.renesas.com> Signed-off-by: Khang Nguyen <khang.nguyen.xv@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
Diffstat (limited to 'meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb')
-rw-r--r--meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb29
1 files changed, 11 insertions, 18 deletions
diff --git a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
index 56edb1f..addda0a 100644
--- a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
+++ b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
@@ -9,13 +9,14 @@ require include/adsp-control.inc
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/:"
COMPATIBLE_MACHINE = "salvator-x|h3ulcb|m3ulcb|ebisu"
-RENESAS_BSP_URL = "git://git.kernel.org/pub/scm/linux/kernel/git/horms/renesas-bsp.git"
-BRANCH = "v4.14.70-ltsi-rc1/rcar-3.8.0"
-SRCREV = "52f8a317698424fe3a4ba7f88d2b87fc6bf6591d"
+RENESAS_BSP_URL = " \
+ git://git.kernel.org/pub/scm/linux/kernel/git/horms/renesas-bsp.git"
+BRANCH = "v4.14.75-ltsi/rcar-3.9.2"
+SRCREV = "a5266d298124874c2c06b8b13d073f6ecc2ee355"
SRC_URI = "${RENESAS_BSP_URL};protocol=git;nocheckout=1;branch=${BRANCH}"
-LINUX_VERSION ?= "4.14.70"
+LINUX_VERSION ?= "4.14.75"
PV = "${LINUX_VERSION}+git${SRCPV}"
PR = "r1"
@@ -40,22 +41,14 @@ SRC_URI_append = " \
${@base_conditional("USE_CAS", "1", " file://capacity_aware_migration_strategy.cfg", "",d)} \
"
-# Device tree patches
-SRC_URI_append = " \
- file://0001-arm64-dts-salvator-common-Rcar-Sound.patch \
- file://0002-arm64-dts-r8a7796-salvator-xs-Remove-Sound-Card.patch \
- file://0003-arm64-dts-r8a7795-salvator-x-Remove-Sound-Card.patch \
- file://0004-arm64-dts-r8a7795-salvator-xs-Remove-Sound-Card.patch \
- file://0005-arm64-dts-r8a7795-es1-salvator-x-Remove-Sound-Card.patch \
- file://0006-arm64-dts-r8a7796-salvator-x-Remove-Sound-Card.patch \
-"
-
# Add ADSP ALSA driver
SUPPORT_ADSP_ASOC = " \
- file://0001-Add-build-for-ADSP-sound-driver.patch \
- file://0002-Add-document-file-for-ADSP-sound-driver.patch \
- file://0003-Add-ADSP-sound-driver-source.patch \
- file://0004-Update-device-tree-for-ADSP-sound-driver.patch \
+ file://0001-ADSP-add-document-for-compatible-string-renesas-rcar.patch \
+ file://0002-ADSP-add-ADSP-sound-driver-source.patch \
+ file://0003-ADSP-add-build-for-ADSP-sound-driver.patch \
+ file://0004-ADSP-integrate-ADSP-sound-for-H3-M3-M3N-board.patch \
+ file://0005-ADSP-integrate-ADSP-sound-for-E3-board.patch \
+ file://0006-ADSP-remove-HDMI-support-from-rcar-sound.patch \
file://adsp.cfg \
"