aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
diff options
context:
space:
mode:
authorKhang Nguyen <khang.nguyen.xv@rvc.renesas.com>2018-03-15 18:00:59 +0700
committerKhang Nguyen <khang.nguyen.xv@rvc.renesas.com>2018-03-22 13:36:54 +0700
commite05044a3d4004a7a3834fa3754a01bb9f5d4c615 (patch)
tree991eea81df57327a30f666749e5ee26be332367d /meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
parent7276dbc4e6a1d9199dbade162cb1d144bf5cd4f4 (diff)
rcar-gen3: linux-renesas: Ensure only build CAS with H3 or M3 SoC
CAS only supports H3 (SoC: r8a7795), M3 (SoC: r8a7796). This commit adds a python function to disable CAS automatically and show the warning message as below in case of wrong setup. | WARNING: linux-renesas-4.14.0+gitAUTOINC+4a7e26bdbc-r1 do_cas_checking: | CAS only supports H3 (SoC: r8a7795), M3 (SoC: r8a7796), this feature will be disabled automatically Signed-off-by: Khang Nguyen <khang.nguyen.xv@rvc.renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
Diffstat (limited to 'meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb')
-rw-r--r--meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
index 5cce5ba..29039b9 100644
--- a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
+++ b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
@@ -3,6 +3,7 @@ DESCRIPTION = "Linux kernel for the R-Car Generation 3 based board"
require include/avb-control.inc
require include/iccom-control.inc
require recipes-kernel/linux/linux-yocto.inc
+require include/cas-control.inc
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/:"
COMPATIBLE_MACHINE = "salvator-x|h3ulcb|m3ulcb|ebisu"
@@ -35,7 +36,7 @@ SRC_URI_append = " \
# Add SCHED_DEBUG config fragment to support CAS
SRC_URI_append = " \
- ${@bb.utils.contains('MACHINE_FEATURES','cas','file://capacity_aware_migration_strategy.cfg','',d)} \
+ ${@base_conditional("USE_CAS", "1", " file://capacity_aware_migration_strategy.cfg", "",d)} \
"
# Install USB3.0 firmware to rootfs