aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-kernel
diff options
context:
space:
mode:
authorThuy Tran <thuy.tran.xh@renesas.com>2018-10-29 17:38:10 +0900
committerDuy Dang <duy.dang.yw@renesas.com>2019-09-23 11:16:37 +0700
commit905d0f09cfeb79553fd8f3a15696006a2ce20c97 (patch)
tree9899710250a405a2f4df809d68035f478c75eba6 /meta-rcar-gen3/recipes-kernel
parentad3a8cfee5b6a6fab17cf1c6e5af851eaec75bd7 (diff)
rcar-gen3: Change base_conditional to oe.utils.conditional
This commit changes to use oe.utils.conditional because these base_* functions were removed in meta/lib/oe from YP2.5. (From Poky rev: 58449f0e9cc4a05c88204cf8ba887b55467d886e) Signed-off-by: Thuy Tran <thuy.tran.xh@renesas.com> Signed-off-by: Khang Nguyen <khang.nguyen.xw@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com> Change-Id: Iee8ccb134de4b955032427bd06c230c32c7084cf
Diffstat (limited to 'meta-rcar-gen3/recipes-kernel')
-rw-r--r--meta-rcar-gen3/recipes-kernel/kernel-module-uvcs/kernel-module-uvcs-drv.bb2
-rw-r--r--meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.14.bb4
-rw-r--r--meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb8
3 files changed, 7 insertions, 7 deletions
diff --git a/meta-rcar-gen3/recipes-kernel/kernel-module-uvcs/kernel-module-uvcs-drv.bb b/meta-rcar-gen3/recipes-kernel/kernel-module-uvcs/kernel-module-uvcs-drv.bb
index b7ba373..6d0b9f6 100644
--- a/meta-rcar-gen3/recipes-kernel/kernel-module-uvcs/kernel-module-uvcs-drv.bb
+++ b/meta-rcar-gen3/recipes-kernel/kernel-module-uvcs/kernel-module-uvcs-drv.bb
@@ -16,7 +16,7 @@ require include/rcar-gen3-path-common.inc
inherit module
PR = "r0"
-SRC_URI = "${@base_conditional('USE_VIDEO_OMX', '1', 'file://RCG3VUDRL4101ZDO.tar.bz2', '', d)}"
+SRC_URI = "${@oe.utils.conditional('USE_VIDEO_OMX', '1', 'file://RCG3VUDRL4101ZDO.tar.bz2', '', d)}"
S = "${WORKDIR}/RCG3VUDRL4101ZDO"
diff --git a/meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.14.bb b/meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.14.bb
index 9f4529e..1a1f53e 100644
--- a/meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.14.bb
+++ b/meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.14.bb
@@ -11,7 +11,7 @@ SRC_URI = "${RENESAS_BSP_URL};branch=${BRANCH}"
# Enable RPMSG_VIRTIO depend on ICCOM
SRC_URI_append = " \
- ${@base_conditional("USE_ICCOM", "1", " file://0001-rpmsg-Add-message-to-be-able-to-configure-RPMSG_VIRT.patch", "", d)} \
+ ${@oe.utils.conditional("USE_ICCOM", "1", " file://0001-rpmsg-Add-message-to-be-able-to-configure-RPMSG_VIRT.patch", "", d)} \
"
# Add ADSP ALSA driver
@@ -25,7 +25,7 @@ SUPPORT_ADSP_ASOC = " \
"
SRC_URI_append = " \
- ${@base_conditional("USE_ADSP", "1", "${SUPPORT_ADSP_ASOC}", "", d)} \
+ ${@oe.utils.conditional("USE_ADSP", "1", "${SUPPORT_ADSP_ASOC}", "", d)} \
"
S = "${WORKDIR}/git"
diff --git a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
index 9355cd0..3faeab1 100644
--- a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
+++ b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
@@ -23,7 +23,7 @@ PR = "r1"
SRC_URI_append = " \
file://defconfig \
file://touch.cfg \
- ${@base_conditional("USE_AVB", "1", " file://usb-video-class.cfg", "", d)} \
+ ${@oe.utils.conditional("USE_AVB", "1", " file://usb-video-class.cfg", "", d)} \
"
# Enable RPMSG_VIRTIO depend on ICCOM
@@ -33,12 +33,12 @@ SUPPORT_ICCOM = " \
"
SRC_URI_append = " \
- ${@base_conditional("USE_ICCOM", "1", "${SUPPORT_ICCOM}", "", d)} \
+ ${@oe.utils.conditional("USE_ICCOM", "1", "${SUPPORT_ICCOM}", "", d)} \
"
# Add SCHED_DEBUG config fragment to support CAS
SRC_URI_append = " \
- ${@base_conditional("USE_CAS", "1", " file://capacity_aware_migration_strategy.cfg", "",d)} \
+ ${@oe.utils.conditional("USE_CAS", "1", " file://capacity_aware_migration_strategy.cfg", "",d)} \
"
# Add ADSP ALSA driver
@@ -53,7 +53,7 @@ SUPPORT_ADSP_ASOC = " \
"
SRC_URI_append = " \
- ${@base_conditional("USE_ADSP", "1", "${SUPPORT_ADSP_ASOC}", "", d)} \
+ ${@oe.utils.conditional("USE_ADSP", "1", "${SUPPORT_ADSP_ASOC}", "", d)} \
"
# Install USB3.0 firmware to rootfs