summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-rcar-gen3/recipes-bsp/optee/optee-client/0001-Add-LDFLAGS-option.patch39
-rw-r--r--meta-rcar-gen3/recipes-bsp/optee/optee-client_git.bb5
2 files changed, 2 insertions, 42 deletions
diff --git a/meta-rcar-gen3/recipes-bsp/optee/optee-client/0001-Add-LDFLAGS-option.patch b/meta-rcar-gen3/recipes-bsp/optee/optee-client/0001-Add-LDFLAGS-option.patch
deleted file mode 100644
index 94d25ff..0000000
--- a/meta-rcar-gen3/recipes-bsp/optee/optee-client/0001-Add-LDFLAGS-option.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 2035e9a30a235204b3d96ec369ad601dfd93579d Mon Sep 17 00:00:00 2001
-From: Jun Miyauchi <jun.miyauchi.sr@hitachi.com>
-Date: Fri, 22 Dec 2017 09:13:57 +0900
-Subject: [PATCH] Add LDFLAGS option
-
----
- libteec/Makefile | 2 +-
- tee-supplicant/Makefile | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/libteec/Makefile b/libteec/Makefile
-index 568a2cd..a9cca19 100644
---- a/libteec/Makefile
-+++ b/libteec/Makefile
-@@ -45,7 +45,7 @@ libteec: $(TEEC_LIBRARY)
-
- $(TEEC_LIBRARY): $(TEEC_OBJS)
- @echo " LINK $@"
-- $(VPREFIX)$(CC) -shared -Wl,-soname,$(LIB_MAJ_MIN) $(TEEC_LFLAGS) -o $@ $+
-+ $(VPREFIX)$(CC) $(LDFLAGS) -shared -Wl,-soname,$(LIB_MAJ_MIN) $(TEEC_LFLAGS) -o $@ $+
- @echo ""
-
- $(TEEC_OBJ_DIR)/%.o: ${TEEC_SRC_DIR}/%.c
-diff --git a/tee-supplicant/Makefile b/tee-supplicant/Makefile
-index 737d39a..98e7408 100644
---- a/tee-supplicant/Makefile
-+++ b/tee-supplicant/Makefile
-@@ -69,7 +69,7 @@ tee-supplicant: $(TEES_FILE)
-
- $(TEES_FILE): $(TEES_OBJS)
- @echo " LINK $@"
-- $(VPREFIX)$(CC) -o $@ $+ $(TEES_LDFLAGS)
-+ $(VPREFIX)$(CC) $(LDFLAGS) -o $@ $+ $(TEES_LDFLAGS)
- @echo ""
-
- $(TEES_OBJ_DIR)/%.o: $(TEES_SRC_DIR)/%.c
---
-2.14.1.windows.1
-
diff --git a/meta-rcar-gen3/recipes-bsp/optee/optee-client_git.bb b/meta-rcar-gen3/recipes-bsp/optee/optee-client_git.bb
index 4075532..3ed3239 100644
--- a/meta-rcar-gen3/recipes-bsp/optee/optee-client_git.bb
+++ b/meta-rcar-gen3/recipes-bsp/optee/optee-client_git.bb
@@ -6,10 +6,9 @@ PR = "r0"
PV = "2.6.0+renesas+git${SRCPV}"
BRANCH = "master"
SRC_URI = "git://github.com/OP-TEE/optee_client.git;branch=${BRANCH}"
-SRCREV = "73b4e490a8ed0b4a7714818e80998b9d8a7da958"
+SRCREV = "2d542f2074223fde918e68efa4a9ff37f927e604"
SRC_URI += " \
- file://0001-Add-LDFLAGS-option.patch \
file://optee.service \
"
@@ -22,7 +21,7 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
S = "${WORKDIR}/git"
-EXTRA_OEMAKE = "RPMB_EMU=0"
+EXTRA_OEMAKE = "RPMB_EMU=0 CFLAGS='${CFLAGS}'"
do_install () {
# Create destination directories