aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-graphics/mesa/mesa_11.%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-rcar-gen3/recipes-graphics/mesa/mesa_11.%.bbappend')
-rw-r--r--meta-rcar-gen3/recipes-graphics/mesa/mesa_11.%.bbappend10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-graphics/mesa/mesa_11.%.bbappend b/meta-rcar-gen3/recipes-graphics/mesa/mesa_11.%.bbappend
new file mode 100644
index 0000000..e1b7ad2
--- /dev/null
+++ b/meta-rcar-gen3/recipes-graphics/mesa/mesa_11.%.bbappend
@@ -0,0 +1,10 @@
+require include/gles-control.inc
+
+def map_libs(d):
+ if base_conditional('USE_GLES_WAYLAND', "1", "1", "0", d) == "1":
+ return "wayland"
+
+ return "dummy"
+
+MESATARGET := "${@map_libs(d)}"
+include mesa-${MESATARGET}.inc