aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-graphics
diff options
context:
space:
mode:
Diffstat (limited to 'meta-rcar-gen3/recipes-graphics')
-rw-r--r--meta-rcar-gen3/recipes-graphics/images/core-image-renesas-base.inc4
-rw-r--r--meta-rcar-gen3/recipes-graphics/images/core-image-renesas-mmp-base.inc32
-rw-r--r--meta-rcar-gen3/recipes-graphics/mesa/mesa_%.bbappend2
-rw-r--r--meta-rcar-gen3/recipes-graphics/wayland/weston.inc8
-rw-r--r--meta-rcar-gen3/recipes-graphics/wayland/weston_2.0.0.bbappend2
5 files changed, 24 insertions, 24 deletions
diff --git a/meta-rcar-gen3/recipes-graphics/images/core-image-renesas-base.inc b/meta-rcar-gen3/recipes-graphics/images/core-image-renesas-base.inc
index 013cf2c..67615b1 100644
--- a/meta-rcar-gen3/recipes-graphics/images/core-image-renesas-base.inc
+++ b/meta-rcar-gen3/recipes-graphics/images/core-image-renesas-base.inc
@@ -39,7 +39,7 @@ BASIC_32BIT_PKGS = " \
# Installation for 32bit packages
IMAGE_INSTALL_append = " \
- ${@base_conditional("USE_32BIT_PKGS", "1", "${BASIC_32BIT_PKGS}", "", d)} \
+ ${@oe.utils.conditional("USE_32BIT_PKGS", "1", "${BASIC_32BIT_PKGS}", "", d)} \
"
# Kernel modules of ICCOM
@@ -63,5 +63,5 @@ ICCOM_PKGS = " \
# Installation for ICCOM Packages
IMAGE_INSTALL_append = " \
- ${@base_conditional("USE_ICCOM", "1", " ${ICCOM_PKGS}", "", d)} \
+ ${@oe.utils.conditional("USE_ICCOM", "1", " ${ICCOM_PKGS}", "", d)} \
"
diff --git a/meta-rcar-gen3/recipes-graphics/images/core-image-renesas-mmp-base.inc b/meta-rcar-gen3/recipes-graphics/images/core-image-renesas-mmp-base.inc
index b559a0b..8806220 100644
--- a/meta-rcar-gen3/recipes-graphics/images/core-image-renesas-mmp-base.inc
+++ b/meta-rcar-gen3/recipes-graphics/images/core-image-renesas-mmp-base.inc
@@ -79,24 +79,24 @@ AVB_PKGS = " \
# Renesas MMP 32bit packages
MMP_32BIT_PKGS = " \
- ${@base_conditional("USE_MULTIMEDIA", "1", "lib32-packagegroup-multimedia-libs lib32-omx-user-module", "", d)} \
- ${@base_conditional("USE_MULTIMEDIA_TP", "1", "lib32-vspmif-tp-user-module", "", d)} \
- ${@base_conditional("USE_CMS", "1", "lib32-cms-user-module", "", d)} \
- ${@base_conditional("USE_DTV", "1", "lib32-dtv-user-module", "", d)} \
- ${@base_conditional("USE_DVD", "1", "lib32-dvd-user-module", "", d)} \
- ${@base_conditional("USE_ADSP", "1", "lib32-adsp-if-module", "", d)} \
+ ${@oe.utils.conditional("USE_MULTIMEDIA", "1", "lib32-packagegroup-multimedia-libs lib32-omx-user-module", "", d)} \
+ ${@oe.utils.conditional("USE_MULTIMEDIA_TP", "1", "lib32-vspmif-tp-user-module", "", d)} \
+ ${@oe.utils.conditional("USE_CMS", "1", "lib32-cms-user-module", "", d)} \
+ ${@oe.utils.conditional("USE_DTV", "1", "lib32-dtv-user-module", "", d)} \
+ ${@oe.utils.conditional("USE_DVD", "1", "lib32-dvd-user-module", "", d)} \
+ ${@oe.utils.conditional("USE_ADSP", "1", "lib32-adsp-if-module", "", d)} \
"
# Install pkg selection
IMAGE_INSTALL_append = " \
- ${@base_conditional("USE_MULTIMEDIA", "1", " ${MULTIMEDIA_PKGS}", "", d)} \
- ${@base_conditional("USE_MULTIMEDIA_TP", "1", " ${MULTIMEDIA_TP_PKGS}", "", d)} \
- ${@base_conditional("USE_OMX_USER_MODULE", "1", " ${OMX_MULTIMEDIA_PKGS}", "", d)} \
- ${@base_conditional("USE_CMS", "1", " ${CMS_MULTIMEDIA_PKGS}", "", d)} \
- ${@base_conditional("USE_DTV", "1", " ${DTV_PKGS}", "", d)} \
- ${@base_conditional("USE_DVD", "1", " ${DVD_PKGS}", "", d)} \
- ${@base_conditional("USE_DVD_ENCRYPTION_LIB", "1", " ${DVD_ENCRYPTION_PKGS}", "", d)} \
- ${@base_conditional("USE_ADSP", "1", " ${ADSP_PKGS}", "", d)} \
- ${@base_conditional("USE_AVB", "1", " ${AVB_PKGS}", "", d)} \
- ${@base_conditional("USE_32BIT_MMP", "1", " ${MMP_32BIT_PKGS}", "", d)} \
+ ${@oe.utils.conditional("USE_MULTIMEDIA", "1", " ${MULTIMEDIA_PKGS}", "", d)} \
+ ${@oe.utils.conditional("USE_MULTIMEDIA_TP", "1", " ${MULTIMEDIA_TP_PKGS}", "", d)} \
+ ${@oe.utils.conditional("USE_OMX_USER_MODULE", "1", " ${OMX_MULTIMEDIA_PKGS}", "", d)} \
+ ${@oe.utils.conditional("USE_CMS", "1", " ${CMS_MULTIMEDIA_PKGS}", "", d)} \
+ ${@oe.utils.conditional("USE_DTV", "1", " ${DTV_PKGS}", "", d)} \
+ ${@oe.utils.conditional("USE_DVD", "1", " ${DVD_PKGS}", "", d)} \
+ ${@oe.utils.conditional("USE_DVD_ENCRYPTION_LIB", "1", " ${DVD_ENCRYPTION_PKGS}", "", d)} \
+ ${@oe.utils.conditional("USE_ADSP", "1", " ${ADSP_PKGS}", "", d)} \
+ ${@oe.utils.conditional("USE_AVB", "1", " ${AVB_PKGS}", "", d)} \
+ ${@oe.utils.conditional("USE_32BIT_MMP", "1", " ${MMP_32BIT_PKGS}", "", d)} \
"
diff --git a/meta-rcar-gen3/recipes-graphics/mesa/mesa_%.bbappend b/meta-rcar-gen3/recipes-graphics/mesa/mesa_%.bbappend
index e1b7ad2..022144e 100644
--- a/meta-rcar-gen3/recipes-graphics/mesa/mesa_%.bbappend
+++ b/meta-rcar-gen3/recipes-graphics/mesa/mesa_%.bbappend
@@ -1,7 +1,7 @@
require include/gles-control.inc
def map_libs(d):
- if base_conditional('USE_GLES_WAYLAND', "1", "1", "0", d) == "1":
+ if oe.utils.conditional('USE_GLES_WAYLAND', "1", "1", "0", d) == "1":
return "wayland"
return "dummy"
diff --git a/meta-rcar-gen3/recipes-graphics/wayland/weston.inc b/meta-rcar-gen3/recipes-graphics/wayland/weston.inc
index e475aea..c1cc206 100644
--- a/meta-rcar-gen3/recipes-graphics/wayland/weston.inc
+++ b/meta-rcar-gen3/recipes-graphics/wayland/weston.inc
@@ -3,14 +3,14 @@ require include/multimedia-control.inc
PACKAGECONFIG_remove_virtclass-multilib-lib32 = "launch"
DEPENDS_append = " \
- ${@base_conditional('USE_GLES', '1', ' libgbm', '', d)}"
+ ${@oe.utils.conditional('USE_GLES', '1', ' libgbm', '', d)}"
RDEPENDS_${PN}_append = " \
- ${@base_conditional('USE_GLES', '1', ' libgbm', '', d)} \
+ ${@oe.utils.conditional('USE_GLES', '1', ' libgbm', '', d)} \
"
RDEPENDS_${PN}-examples_append = " \
- ${@base_conditional('USE_GLES', '1', ' libgbm', '', d)}"
+ ${@oe.utils.conditional('USE_GLES', '1', ' libgbm', '', d)}"
EXTRA_OECONF_append = " \
- ${@base_conditional('USE_GLES', '1', '', \
+ ${@oe.utils.conditional('USE_GLES', '1', '', \
' WESTON_NATIVE_BACKEND="fbdev-backend.so"', d)}"
diff --git a/meta-rcar-gen3/recipes-graphics/wayland/weston_2.0.0.bbappend b/meta-rcar-gen3/recipes-graphics/wayland/weston_2.0.0.bbappend
index a261745..fced56c 100644
--- a/meta-rcar-gen3/recipes-graphics/wayland/weston_2.0.0.bbappend
+++ b/meta-rcar-gen3/recipes-graphics/wayland/weston_2.0.0.bbappend
@@ -21,7 +21,7 @@ SRC_URI_append = " \
S = "${WORKDIR}/git"
PACKAGECONFIG_append = " \
- ${@base_conditional('USE_MULTIMEDIA', '1', ' v4l2', '', d)} \
+ ${@oe.utils.conditional('USE_MULTIMEDIA', '1', ' v4l2', '', d)} \
"
PACKAGECONFIG[v4l2] = " --enable-v4l2, --disable-v4l2,,kernel-module-vsp2driver"