aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2017-04-24 21:56:57 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2017-04-24 21:58:03 +0200
commit187a1ae97a9bf5fd6e3acda38a587d2507c6b88d (patch)
tree89a9666da8f88d0bcf7c755ae0becb284f1d1f1b
parentfd5fb4d934969b6affb611e7b76bd8e578814c67 (diff)
Fix the dynamic asound.state file installation
This is a follow-up fix for SPEC-553. We need to install the chosen file. Change-Id: I2471dd3b5ad47ca01706c61ee89ea3a1d895da39 Bug-AGL: SPEC-553 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-rcar-gen2/recipes-multimedia/alsa/alsa-utils-config.bb11
1 files changed, 7 insertions, 4 deletions
diff --git a/meta-rcar-gen2/recipes-multimedia/alsa/alsa-utils-config.bb b/meta-rcar-gen2/recipes-multimedia/alsa/alsa-utils-config.bb
index 10cdcaf..db616ce 100644
--- a/meta-rcar-gen2/recipes-multimedia/alsa/alsa-utils-config.bb
+++ b/meta-rcar-gen2/recipes-multimedia/alsa/alsa-utils-config.bb
@@ -10,16 +10,19 @@ FILESEXTRAPATHS_prepend = "${THISDIR}/alsa-utils-config:"
SRC_URI = "file://COPYING \
"
-SRC_URI_append_porter = "file://asound.state-porter"
-SRC_URI_append_koelsch = "file://asound.state-porter"
-# SRC_URI_append_silk = "file://asound.state-silk"
+
+ASOUNDSTATEFILE_porter = "asound.state-porter"
+ASOUNDSTATEFILE_koelsch = "asound.state-porter"
+#ASOUNDSTATEFILE_silk = "asound.state-silk"
+
+SRC_URI_append = " file://${ASOUNDSTATEFILE}"
# package with no tarball
S = "${WORKDIR}"
do_install() {
install -d ${D}/${localstatedir}/lib/alsa
- install -m 0644 asound.state ${D}/${localstatedir}/lib/alsa
+ install -m 0644 ${ASOUNDSTATEFILE} ${D}/${localstatedir}/lib/alsa/asound.state
}
FILES_${PN} += "${localstatedir}"