aboutsummaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel/linux-fusion/linux-fusion/linux-fusion-modules-replace-KERNELDIR-with-KERNEL_SRC.patch
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-kernel/linux-fusion/linux-fusion/linux-fusion-modules-replace-KERNELDIR-with-KERNEL_SRC.patch')
-rw-r--r--common/recipes-kernel/linux-fusion/linux-fusion/linux-fusion-modules-replace-KERNELDIR-with-KERNEL_SRC.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/common/recipes-kernel/linux-fusion/linux-fusion/linux-fusion-modules-replace-KERNELDIR-with-KERNEL_SRC.patch b/common/recipes-kernel/linux-fusion/linux-fusion/linux-fusion-modules-replace-KERNELDIR-with-KERNEL_SRC.patch
new file mode 100644
index 0000000..22f8e25
--- /dev/null
+++ b/common/recipes-kernel/linux-fusion/linux-fusion/linux-fusion-modules-replace-KERNELDIR-with-KERNEL_SRC.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index 0115a44..cb2856b 100644
+--- a/Makefile
++++ b/Makefile
+@@ -25,7 +25,7 @@ ONE_CPPFLAGS += \
+ -I`pwd`/one/$(ONECORE) \
+ -I`pwd`/include \
+
+-KERNEL_BUILD = $(KERNELDIR)
++KERNEL_BUILD = $(KERNEL_SRC)
+ # works for 2.6.23
+ KERNEL_SOURCE = $(shell grep ^KERNELSRC $(KERNEL_BUILD)/Makefile | cut -d ' ' -f 6)
+ ifeq ($(KERNEL_SOURCE), )