aboutsummaryrefslogtreecommitdiffstats
path: root/common/recipes-multimedia/gstreamer/gst-plugins-bad_0.10.23.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-multimedia/gstreamer/gst-plugins-bad_0.10.23.bbappend')
-rw-r--r--common/recipes-multimedia/gstreamer/gst-plugins-bad_0.10.23.bbappend27
1 files changed, 27 insertions, 0 deletions
diff --git a/common/recipes-multimedia/gstreamer/gst-plugins-bad_0.10.23.bbappend b/common/recipes-multimedia/gstreamer/gst-plugins-bad_0.10.23.bbappend
new file mode 100644
index 0000000..6dd2399
--- /dev/null
+++ b/common/recipes-multimedia/gstreamer/gst-plugins-bad_0.10.23.bbappend
@@ -0,0 +1,27 @@
+DEPENDS += "gstreamer libxml2"
+EXTRA_OECONF := "${@'${EXTRA_OECONF}'.replace('--disable-experimental', '--enable-experimental')}"
+EXTRA_OECONF += "--with-plugins=h264parse,asfmux,videoparsers"
+
+TARGET_CFLAGS += "-D_GNU_SOURCE"
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+# For armadillo
+SRCREV_armadillo800eva = "6c0a11cb57d4425f6d721a6756c5af4d9dd269e5"
+SRC_URI_armadillo800eva = "git://github.com/matsu/gst-plugins-bad.git \
+ file://0001-Setup-MERAM-for-A1.patch"
+S_armadillo800eva = "${WORKDIR}/git/"
+DEPENDS_append_armadillo800eva = " directfb libuiomux libshvio"
+EXTRA_OECONF_armadillo800eva := "${@'${EXTRA_OECONF}'.replace('--disable-directfb', '--enable-directfb')}"
+
+EXTRA_OECONF_append_armadillo800eva = " \
+ --disable-librfb --enable-introspection=no \
+ --disable-nls --disable-static --disable-gsettings \
+"
+
+do_configure_armadillo800eva() {
+ (cd ${S}; sh autogen.sh --noconfigure)
+ oe_runconf
+}
+
+FILES_${PN} += "${bindir}"
+require gst-plugins-private-libs.inc