summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOuyang Jun <ouyangj.fnst@cn.fujitsu.com>2019-07-24 04:33:26 -0700
committerOuyang Jun <ouyangj.fnst@cn.fujitsu.com>2019-07-25 00:35:57 -0700
commita61b0a9931e16a51fd819167cc597d84b52ad266 (patch)
tree55ec9cba45cb9518911b497f78573dabc4bebecc /CMakeLists.txt
parent33258140525123d6a38900811c2df3e14f4e8337 (diff)
Minimal cluster demo gauges that can be used standalone
Bug-AGL: SPEC-2487 Signed-off-by: Ouyang Jun <ouyangj.fnst@cn.fujitsu.com> Signed-off-by: Zhou Mingying <zhoumy@cn.fujitsu.com> Signed-off-by: Liu Wenlong <liuwl.fnst@cn.fujitsu.com> Change-Id: I4859ab9af2f5c3bbeff5ca6b14a7943797518908
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..bf284f7
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,21 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# Author: romain Forlot <romain.forlot@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+CMAKE_MINIMUM_REQUIRED(VERSION 3.3)
+
+include(${CMAKE_CURRENT_SOURCE_DIR}/conf.d/cmake/config.cmake)