aboutsummaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorEdi Feschiyan <edi.feschiyan@konsulko.com>2019-06-13 13:05:25 +0300
committerEdi Feschiyan <edi.feschiyan@konsulko.com>2019-06-18 00:07:19 +0300
commite3ef5052d65cc158235fbb5d8053d9b1d7731d51 (patch)
tree6e6fb6f13adadfdedc9b92c44b214f60acfd8f68 /test/CMakeLists.txt
parent4143c81945126d4f1839a1047aa96a75f1e4c690 (diff)
Adding tests for agl-service-bluetooth.
Commented tests needing real hardware device at the bottom. Bug-AGL: SPEC-2523 Signed-off-by: Edi Feschiyan <edi.feschiyan@konsulko.com> Change-Id: Iee0126665af34654d14e8bcd018175fc772f1ce3
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
new file mode 100644
index 0000000..75bcf58
--- /dev/null
+++ b/test/CMakeLists.txt
@@ -0,0 +1,28 @@
+###########################################################################
+# Copyright 2019 Konsulko Group
+#
+# author:Stoyan Bogdanov <stoyan.bogdanov@konsulko.com>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+
+# Include any directory not starting with _
+# -----------------------------------------------------
+PROJECT_SUBDIRS_ADD(${PROJECT_SRC_DIR_PATTERN})
+
+ADD_TEST(NAME AGL_SERVICE_GPS_TESTS
+ WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
+ COMMAND afb-test.sh "${CMAKE_BINARY_DIR}/package" "${CMAKE_BINARY_DIR}/package-test" SERVICE
+ )
+