aboutsummaryrefslogtreecommitdiffstats
path: root/test/afb-test/etc/CMakeLists.txt
diff options
context:
space:
mode:
authorLi, Xiaoming <lixm.fnst@cn.fujitsu.com>2020-07-13 14:50:23 +0800
committerLi Xiaoming <lixm.fnst@cn.fujitsu.com>2020-07-13 06:54:02 +0000
commit61e59bb7c3e2b29bafa59d448f460774ccdc41c6 (patch)
tree415e74f6aafef8a80d913003da2f48ddcd0cdeb6 /test/afb-test/etc/CMakeLists.txt
parentcb15de5ff7e348a529a90f7bbdc4f6dabac58241 (diff)
- Create the file and folders structure required. for building test bindings. Add all required Cmake files. - Create aft-agl-high-viwi.json configuration file for testing binding. - Create high-viwi.lua for testing bindings. Bug-AGL: SPEC-3458 Change-Id: Iaeeb62db12ab8bafcc8fab82525343b2d81fe89b Signed-off-by: Li, Xiaoming <lixm.fnst@cn.fujitsu.com>
Diffstat (limited to 'test/afb-test/etc/CMakeLists.txt')
-rw-r--r--test/afb-test/etc/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/test/afb-test/etc/CMakeLists.txt b/test/afb-test/etc/CMakeLists.txt
new file mode 100644
index 0000000..fc74bc3
--- /dev/null
+++ b/test/afb-test/etc/CMakeLists.txt
@@ -0,0 +1,32 @@
+###########################################################################
+# Copyright 2020 Fujitsu
+#
+# author:Li Xiaoming <lixm.fnst@cn.fujitsu.com>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+##################################################
+# High level can binding test configuration files
+##################################################
+PROJECT_TARGET_ADD(afb-test-config)
+
+ file(GLOB CONF_FILES "*.json")
+
+ add_input_files("${CONF_FILES}")
+
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ LABELS "TEST-CONFIG"
+ OUTPUT_NAME ${TARGET_NAME}
+ )
+