aboutsummaryrefslogtreecommitdiffstats
path: root/CAN-binder/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2017-05-02 17:21:20 +0200
committerRomain Forlot <romain.forlot@iot.bzh>2017-05-02 17:21:20 +0200
commit09e762b94a941c9b6f2402c6ea8bf444e13c1574 (patch)
tree13a999a79e4b7776fa3537d45c2e403271ad196a /CAN-binder/CMakeLists.txt
parent39c3d1c6e78ee2f85b713dec39946c05709c1076 (diff)
Using new CMake architecture (again...)
Following the new CMake template from https://gerrit.automotivelinux.org/gerrit/apps/app-templates these CMake files use helpers macros from macros.cmake and project configuration config.cmake. Change-Id: I2297b6ad6c65cd763d1870d5b62564e8795f4317 Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'CAN-binder/CMakeLists.txt')
-rw-r--r--CAN-binder/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CAN-binder/CMakeLists.txt b/CAN-binder/CMakeLists.txt
index 302222e3..56e7860f 100644
--- a/CAN-binder/CMakeLists.txt
+++ b/CAN-binder/CMakeLists.txt
@@ -17,6 +17,12 @@
###########################################################################
CMAKE_MINIMUM_REQUIRED(VERSION 3.3)
-include(${CMAKE_CURRENT_SOURCE_DIR}/etc/agl.cmake)
+
+include(${CMAKE_CURRENT_SOURCE_DIR}/etc/config.cmake)
+include(${CMAKE_CURRENT_SOURCE_DIR}/etc/macros.cmake)
+
+# Bindings to compile
+# --------------------
+search_targets()
build_widget()