aboutsummaryrefslogtreecommitdiffstats
path: root/CAN-binder/libs/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2017-05-02 18:29:37 +0200
committerRomain Forlot <romain.forlot@iot.bzh>2017-05-02 18:29:37 +0200
commitb9e1b4435a406a8a27c078ea05dee1240e51704a (patch)
tree3bd5e75d001d0c1d57710c47375af5c8ba84c26c /CAN-binder/libs/CMakeLists.txt
parent0242c26c2f5dc96387bca7efb118364c800f4ee7 (diff)
Added external libraries from openXC CMake files.
Now libraries are cleanly included and built. Change-Id: Iaa85639578b55b2da8357bc438426403e2cca8de Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'CAN-binder/libs/CMakeLists.txt')
-rw-r--r--CAN-binder/libs/CMakeLists.txt11
1 files changed, 1 insertions, 10 deletions
diff --git a/CAN-binder/libs/CMakeLists.txt b/CAN-binder/libs/CMakeLists.txt
index 38ccd2d1..cc4af555 100644
--- a/CAN-binder/libs/CMakeLists.txt
+++ b/CAN-binder/libs/CMakeLists.txt
@@ -17,13 +17,4 @@
###########################################################################
# Add target to project dependency list
-fill_include_dir(${CMAKE_CURRENT_SOURCE_DIR})
-file(GLOB filelist "${CMAKE_CURRENT_SOURCE_DIR}/*")
-foreach(filename ${filelist})
- if(IS_DIRECTORY ${filename})
- STRING(REGEX REPLACE "^.*\/(.*)$" "\\1" shortname ${filename})
- find_source_files(${filename})
- PROJECT_TARGET_ADD(${shortname})
- add_library(${shortname} STATIC ${sources_files})
- endif(IS_DIRECTORY ${filename})
-endforeach()
+search_targets() \ No newline at end of file