aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2020-01-07 18:21:33 +0100
committerRomain Forlot <romain.forlot@iot.bzh>2020-01-09 16:25:32 +0100
commit4e6007c395da9a65a4492e1c45d305368761afcc (patch)
tree727e1c8213ba0c65aa8c98fd83dfa3d71e7e5986 /plugins/CMakeLists.txt
parent961e612d5332a91687f5a0365cb42167caab09b5 (diff)
plugins: Conditionnal building of the j1939 plugin
Bug-AGL: SPEC-2988 Change-Id: Idf77aa32ca4fd44163d93d0515f21d51f1d7abd7 Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'plugins/CMakeLists.txt')
-rwxr-xr-xplugins/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/plugins/CMakeLists.txt b/plugins/CMakeLists.txt
index 6d0bc0bf..631c68c1 100755
--- a/plugins/CMakeLists.txt
+++ b/plugins/CMakeLists.txt
@@ -41,3 +41,32 @@ PROJECT_TARGET_ADD(agl-vcar-signals)
bitfield-c
afb-helpers
${link_libraries})
+
+if(WITH_FEATURE_J1939)
+PROJECT_TARGET_ADD(j1939-signals)
+
+ # Define targets
+ ADD_LIBRARY(${TARGET_NAME} MODULE ${TARGET_NAME}.cpp)
+
+ # Alsa Plugin properties
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ LABELS "PLUGIN"
+ PREFIX ""
+ SUFFIX ".ctlso"
+ OUTPUT_NAME ${TARGET_NAME}
+ )
+
+ target_include_directories(${TARGET_NAME}
+ PRIVATE "../low-can-binding")
+
+ # Library dependencies (include updates automatically)
+ TARGET_LINK_LIBRARIES(${TARGET_NAME}
+ low-can
+ ini-config
+ openxc-message-format
+ uds-c
+ isotp-c
+ bitfield-c
+ afb-helpers
+ ${link_libraries})
+endif()