aboutsummaryrefslogtreecommitdiffstats
path: root/CAN-binder/low-can-binding/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CAN-binder/low-can-binding/CMakeLists.txt')
-rw-r--r--CAN-binder/low-can-binding/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CAN-binder/low-can-binding/CMakeLists.txt b/CAN-binder/low-can-binding/CMakeLists.txt
index 6a871dfe..c408388f 100644
--- a/CAN-binder/low-can-binding/CMakeLists.txt
+++ b/CAN-binder/low-can-binding/CMakeLists.txt
@@ -18,11 +18,12 @@
###########################################################################
# Add target to project dependency list
-PROJECT_TARGET_ADD(low-can-binding)
+PROJECT_TARGET_ADD(low-can)
# Define project Targets
add_library(${TARGET_NAME} MODULE
- binding/${TARGET_NAME}.cpp
+ binding/${TARGET_NAME}-hat.cpp
+ binding/${TARGET_NAME}-cb.cpp
binding/configuration.cpp
binding/configuration-generated.cpp
can/can-bus.cpp
@@ -45,7 +46,7 @@ PROJECT_TARGET_ADD(low-can-binding)
# Binder exposes a unique public entry point
SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
- PREFIX ""
+ PREFIX "afs-"
LABELS "BINDING"
LINK_FLAGS ${BINDINGS_LINK_FLAG}
OUTPUT_NAME ${TARGET_NAME}
@@ -64,4 +65,3 @@ PROJECT_TARGET_ADD(low-can-binding)
INSTALL(TARGETS ${TARGET_NAME}
LIBRARY DESTINATION ${BINDINGS_INSTALL_DIR})
- populate_widget()