aboutsummaryrefslogtreecommitdiffstats
path: root/CAN-binder/low-can-demo/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CAN-binder/low-can-demo/CMakeLists.txt')
-rw-r--r--CAN-binder/low-can-demo/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CAN-binder/low-can-demo/CMakeLists.txt b/CAN-binder/low-can-demo/CMakeLists.txt
index 6de2a25b..136053bd 100644
--- a/CAN-binder/low-can-demo/CMakeLists.txt
+++ b/CAN-binder/low-can-demo/CMakeLists.txt
@@ -24,8 +24,8 @@ PROJECT_TARGET_ADD(low-can-demo)
add_custom_command(OUTPUT dist.prod
DEPENDS ${TARGET_NAME}
WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
- COMMAND npm install
- COMMAND gulp build-app-prod
+ COMMAND [ -d "dist.prod" ] || npm install
+ COMMAND [ -d "dist.prod" ] || gulp build-app-prod
COMMAND cp -r dist.prod ${CMAKE_CURRENT_BINARY_DIR})
add_custom_target(${TARGET_NAME} ALL DEPENDS dist.prod)