aboutsummaryrefslogtreecommitdiffstats
path: root/libs/ini-config/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libs/ini-config/CMakeLists.txt')
-rw-r--r--libs/ini-config/CMakeLists.txt38
1 files changed, 38 insertions, 0 deletions
diff --git a/libs/ini-config/CMakeLists.txt b/libs/ini-config/CMakeLists.txt
new file mode 100644
index 00000000..ceb48259
--- /dev/null
+++ b/libs/ini-config/CMakeLists.txt
@@ -0,0 +1,38 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# author: Fulup Ar Foll <fulup@iot.bzh>
+# contrib: Romain Forlot <romain.forlot@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+# Add target to project dependency list
+PROJECT_TARGET_ADD(ini-config)
+
+ # Define project Target
+ add_library(${TARGET_NAME} STATIC ${TARGET_NAME}.cpp)
+
+ # Binder exposes a unique public entry point
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ OUTPUT_NAME ${TARGET_NAME}
+ )
+
+ # Define target includes
+ TARGET_INCLUDE_DIRECTORIES(${TARGET_NAME}
+ PUBLIC ${CMAKE_CURRENT_SOURCE_DIR}
+ )
+
+ # Library dependencies (include updates automatically)
+ TARGET_LINK_LIBRARIES(${TARGET_NAME}
+ ${link_libraries})