aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormaratsabitov <marat.sabitov@mera.com>2020-05-08 18:03:57 +0300
committerMarat Sabitov <marat.sabitov@mera.com>2020-07-09 09:38:01 +0300
commit0cecffd4565b52bd8d200f6bc9f4144f244a6515 (patch)
treec0969bb192bb711c0bd2e2444a66c0060b2e13af /CMakeLists.txt
parentf496bfe75ef0a1ec2658d3fec51866d4c7551282 (diff)
Cloudproxy service allows applications to communicate with clouds. The commit includes the test applications as sample for real client imlementation. Bug-AGL: SPEC-3370 Change-Id: I82d8122e93d01451f4471cc20c706e75c16f1c29 Signed-off-by: maratsabitov <marat.sabitov@mera.com>
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100755
index 0000000..a7f89ba
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,33 @@
+###########################################################################
+# Copyright (C) 2020 MERA
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+project(CloudProxyService C CXX)
+
+cmake_minimum_required(VERSION 3.0)
+
+set(PROJECT_NAME "CloudProxy Service")
+set(PROJECT_VERSION "1.0")
+set(PROJECT_DESCRIPTION "CloudProxy Service")
+set(PROJECT_INCLUDEDIR ${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_INCLUDEDIR})
+set(PROJECT_LIBDIR ${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR})
+set(binding_install_dir ${PREFIX}/lib/cloudproxy)
+set(PROJECT_BINDINGDIR ${binding_install_dir})
+
+# get pkgconfig
+INCLUDE(FindPkgConfig)
+link_libraries(-Wl,--as-needed -Wl,--gc-sections -Wl,--no-undefined)
+
+add_subdirectory(src)