summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorLeonid Lazarev <leonid.lazarev@orioninc.com>2020-07-09 16:59:44 +0300
committerScott Murray <scott.murray@konsulko.com>2020-09-23 16:16:32 +0000
commit08c57b7cc8ddcdbc40c65bd2c2cc40e7fda4d205 (patch)
tree7a77c4ae35888212ed323179c1f660bd0647cc1c /test/CMakeLists.txt
parent2b1651215ca05273138e657d168676c5c22a13e5 (diff)
Test cases for basic functionality verification have been added. Build of the application has been adapted for Cmake templates usage. Bug-AGL: SPEC-3485 Change-Id: Iaa4a5e393ac9971be4176e90fa5aee10a4673cd3 Signed-off-by: Leonid Lazarev <leonid.lazarev@orioninc.com> (cherry picked from commit 329d8ba3fb46b8afc803ad4a9b286cd26141f2f8)
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
new file mode 100644
index 0000000..becb900
--- /dev/null
+++ b/test/CMakeLists.txt
@@ -0,0 +1,28 @@
+###########################################################################
+# Copyright 2019 Konsulko Group
+#
+# author:Stoyan Bogdanov <stoyan.bogdanov@konsulko.com>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+
+# Include any directory not starting with _
+# -----------------------------------------------------
+PROJECT_SUBDIRS_ADD(${PROJECT_SRC_DIR_PATTERN})
+
+ADD_TEST(NAME AGL_SERVICE_CLOUDPROXY_TESTS
+ WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
+ COMMAND afm-test ${CMAKE_BINARY_DIR}/package ${CMAKE_BINARY_DIR}/package-test
+ )
+