aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorwang_zhiqiang <wang_zhiqiang@dl.cn.nexty-ele.com>2018-08-21 14:48:01 +0800
committerwang_zhiqiang <wang_zhiqiang@dl.cn.nexty-ele.com>2018-08-30 14:07:03 +0800
commit534f46b5236e58dd69fd4b4fd019518ffa96778b (patch)
tree52a401208a4a9717e37836752feb08ddb6756aaa /src/CMakeLists.txt
parent32985a3558c4143900e7edd03e3d7dc9d39ce4c5 (diff)
To impove homescreen-service's extensibility, Changed homescreen.c to homescreen.cpp, hs-helper.h/hs-helper.c to hs-helper.hpp. Change-Id: I12301f2eec237b0952830c9050c99475cacebb6d Signed-off-by: wang_zhiqiang <wang_zhiqiang@dl.cn.nexty-ele.com>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 363cdae..dbd7fbe 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -23,8 +23,8 @@ FIND_PACKAGE(Threads)
pkg_check_modules(hs_binding_depends afb-daemon glib-2.0 gio-2.0 gio-unix-2.0 json-c)
set(binding_hs_sources
- homescreen.c
- hs-helper.c)
+ homescreen.cpp
+ hs-helper.cpp)
link_libraries(-Wl,--as-needed -Wl,--gc-sections -Wl,--no-undefined)
include_directories(${PROJECT_SOURCE_DIR}/include)