aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorzheng_wenlong <wenlong_zheng@nexty-ele.com>2017-10-23 11:49:31 +0900
committerZheng Wenlong <wenlong_zheng@nexty-ele.com>2017-10-30 04:15:17 +0000
commit73038bdc74f57b5cf96ddde2974eb7204dd0a868 (patch)
tree9b89601ca928b171938ded09052abc50ef4b8a63 /CMakeLists.txt
parent2ea3e1fa018fb4dd8d8acb80988832df2f5cf10d (diff)
Delete libhomescreen from this gerrit repository
Relocate libhomescreen into its own repository as src/libhomescreen. BUG-AGL: SPEC-993 Change-Id: I481c9b2322a1a112f23facdd930cb36e594919bb Signed-off-by: zheng_wenlong <wenlong_zheng@nexty-ele.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 2 insertions, 11 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 57f56b1..a854b43 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -18,15 +18,14 @@ project(HomeScreenService C CXX)
cmake_minimum_required(VERSION 3.0)
-set(PROJECT_NAME "HomeScreen Service and client library")
+set(PROJECT_NAME "HomeScreen Service 2017")
set(PROJECT_VERSION "1.0")
set(PROJECT_PRETTY_NAME "HM")
-set(PROJECT_DESCRIPTION "HomeScreen Service and client library")
+set(PROJECT_DESCRIPTION "HomeScreen Service 2017")
set(PROJECT_INCLUDEDIR ${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_INCLUDEDIR})
set(PROJECT_LIBDIR ${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR})
set(binding_install_dir ${PREFIX}/lib/homescreen)
set(PROJECT_BINDINGDIR ${binding_install_dir})
-set(LIBSM_INCLUDE_DIR ${CMAKE_SOURCE_DIR}/include)
# get pkgconfig
INCLUDE(FindPkgConfig)
@@ -37,11 +36,3 @@ set(DEBUGMODE "1")
add_definitions(-DDEBUGMODE)
add_subdirectory(src)
-add_subdirectory(libhomescreen)
-add_subdirectory(include)
-
-#generate configure file
-configure_file(homescreen.pc.in homescreen.pc @ONLY)
-INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/homescreen.pc
- DESTINATION
- ${CMAKE_INSTALL_LIBDIR}/pkgconfig)