summaryrefslogtreecommitdiffstats
path: root/systemd/meson.build
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-08-24 15:39:24 -0400
committerScott Murray <scott.murray@konsulko.com>2023-08-24 15:42:30 -0400
commit0a1426d097688912188bcb59ff59d9c596e82b4d (patch)
tree8032edef0f8a6c3bbebe8f4382486f679bb2143f /systemd/meson.build
parentf0ac80936b73a44131564c4f65ecc0c9a9db7d39 (diff)
Rework to switch to using KUKSA.val databroker
Rework to use the "VAL" gRPC API from the KUKSA.val databroker instead of the older server's WebSocket interface. Some source files have been renamed to match the class naming to provide a bit more consistency. Bug-AGL: SPEC-4762 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ib1ec31af439a9b2d5244e2232ea7be1ed9a2574c
Diffstat (limited to 'systemd/meson.build')
-rw-r--r--systemd/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/systemd/meson.build b/systemd/meson.build
index 4551805..d0636cd 100644
--- a/systemd/meson.build
+++ b/systemd/meson.build
@@ -1,3 +1,5 @@
+systemd_dep = dependency('systemd')
+
systemd_system_unit_dir = systemd_dep.get_pkgconfig_variable('systemdsystemunitdir')
install_data('agl-service-hvac.service', install_dir : systemd_system_unit_dir)