aboutsummaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-06-19 13:09:30 +0000
committerGerrit Code Review <gerrit@automotivelinux.org>2019-06-19 13:09:30 +0000
commitba1880a6cf8c750a5b73a3d3003a54622e1f480c (patch)
treec7c3df829fcb9a485bd70b5004735d2bcc57e63d /test/CMakeLists.txt
parentdc7ace58b77c628006fd0c7540b2ca047f67716a (diff)
parente457cf8cd7def62ac97e2b05b6d78726fc7ee96c (diff)
Merge "Adding tests for agl-service-mediaplayer"halibut_7.99.2halibut/7.99.27.99.2
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
new file mode 100644
index 0000000..75bcf58
--- /dev/null
+++ b/test/CMakeLists.txt
@@ -0,0 +1,28 @@
+###########################################################################
+# Copyright 2019 Konsulko Group
+#
+# author:Stoyan Bogdanov <stoyan.bogdanov@konsulko.com>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+
+# Include any directory not starting with _
+# -----------------------------------------------------
+PROJECT_SUBDIRS_ADD(${PROJECT_SRC_DIR_PATTERN})
+
+ADD_TEST(NAME AGL_SERVICE_GPS_TESTS
+ WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
+ COMMAND afb-test.sh "${CMAKE_BINARY_DIR}/package" "${CMAKE_BINARY_DIR}/package-test" SERVICE
+ )
+