aboutsummaryrefslogtreecommitdiffstats
path: root/test/afb-test/CMakeLists.txt
diff options
context:
space:
mode:
authorLi, Xiaoming <lixm.fnst@cn.fujitsu.com>2020-08-03 14:56:05 +0800
committerLi, Xiaoming <lixm.fnst@cn.fujitsu.com>2020-08-03 14:58:17 +0800
commit05bbefa54c7e15b916c2f73c9b0495bdde9c488b (patch)
tree36a0a2d5e03bca93e37012b253a8d4af91ba6bef /test/afb-test/CMakeLists.txt
parent501e7fe07810b294b8af90a6ec2442868ffdd51a (diff)
Add test bindings for agl-service-mediascannerjellyfish_9.99.3jellyfish/9.99.39.99.3
- Create the file and folders structure required. for building test bindings. Add all required Cmake files. - Create aft-agl-mediascanner.json configuration file for testing binding. - Create mediascanner.lua for testing bindings. Bug-AGL: SPEC-3458 Change-Id: If083510932d1a8c79387eaf8d42c5e7ca6b835e5 Signed-off-by: Li, Xiaoming <lixm.fnst@cn.fujitsu.com>
Diffstat (limited to 'test/afb-test/CMakeLists.txt')
-rw-r--r--test/afb-test/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/test/afb-test/CMakeLists.txt b/test/afb-test/CMakeLists.txt
new file mode 100644
index 0000000..4adafb0
--- /dev/null
+++ b/test/afb-test/CMakeLists.txt
@@ -0,0 +1,21 @@
+###########################################################################
+# Copyright 2020 Fujitsu
+#
+# author: Li Xiaoming <lixm.fnst@cn.fujitsu.com>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+# Include any directory not starting with _
+# -----------------------------------------------------
+PROJECT_SUBDIRS_ADD(${PROJECT_SRC_DIR_PATTERN})