aboutsummaryrefslogtreecommitdiffstats
path: root/test/afb-test/CMakeLists.txt
diff options
context:
space:
mode:
authorStoyan Bogdanov <stoyan.bogdanov@konsulko.com>2019-06-21 15:12:37 +0300
committerStoyan Bogdanov <stoyan.bogdanov@konsulko.com>2019-06-21 15:15:31 +0300
commit6463f4536279b81a18dfe8023bf50d9c97a1ee78 (patch)
tree380556407461004820f3baf825494e5aa25da41e /test/afb-test/CMakeLists.txt
parentb43478c07243f63b662f881c5c11c9ff9021cfe9 (diff)
tests: network: Add test bindings for agl-service-network
- Create the file and folders structure required. for building test bindings. Add all required Cmake files. - Create aft-agl-network.json configuration file for testing binding. - Create network.lua for testing bindings. Bug-AGL: SPEC-2539 Signed-off-by: Stoyan Bogdanov <stoyan.bogdanov@konsulko.com> Change-Id: Ibd93f41751339ecac03dab8e83673da55eafb3f6
Diffstat (limited to 'test/afb-test/CMakeLists.txt')
-rw-r--r--test/afb-test/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/test/afb-test/CMakeLists.txt b/test/afb-test/CMakeLists.txt
new file mode 100644
index 0000000..44bfeac
--- /dev/null
+++ b/test/afb-test/CMakeLists.txt
@@ -0,0 +1,21 @@
+###########################################################################
+# Copyright 2019 Konsulko Group
+#
+# Author: Stoyan Bogdanov <stoyan.bogdanov@konsulko.com>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+# Include any directory not starting with _
+# -----------------------------------------------------
+PROJECT_SUBDIRS_ADD(${PROJECT_SRC_DIR_PATTERN})