aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLoïc Collignon <loic.collignon@iot.bzh>2017-10-23 10:51:37 +0200
committerLoïc Collignon <loic.collignon@iot.bzh>2017-10-23 10:51:37 +0200
commit44096523e0c45c6b02840f2fe2aca337510fac28 (patch)
treedc9c7b2be0750c011fd7c581df65f7b2e0a9ec16 /CMakeLists.txt
parent5441251cae0eea3786c327b3b3386eae5bf687db (diff)
add nfc binding
Change-Id: I1ebf8e803436430490201db533c2a5a04c04295e Signed-off-by: Loïc Collignon <loic.collignon@iot.bzh>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..cb875ab
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,26 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# author: Loïc Collignon <loic.collignon@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+CMAKE_MINIMUM_REQUIRED(VERSION 3.3)
+
+option(USE_LIBNFC "Enable or disable the 'libnfc' usage." ON)
+
+include(${CMAKE_CURRENT_SOURCE_DIR}/conf.d/cmake/config.cmake)
+
+install(DIRECTORY htdocs/nfc DESTINATION htdocs)
+install(DIRECTORY etc DESTINATION ./)