aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2018-05-24 22:57:13 -0700
committerMatt Ranostay <matt.ranostay@konsulko.com>2018-07-04 23:18:45 -0700
commit6eb99ceb647cf35c39dc97292f00040fbb821170 (patch)
tree1db97cb18370f6b25902bb06b2e01a74aae169e2 /CMakeLists.txt
parentf9e5259d74c8cf521921a96377c64691b5b3c3ae (diff)
binding: nfc: new initial binding
Slight rewrite to use libnfc initially for getting tag uid's for user settings. Bug-AGL: SPEC-1554 Change-Id: I7b8c30102b82e86a92c89909bcbfba9ab7164c1f Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 1 insertions, 15 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1511ac0..b485097 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,7 +1,7 @@
###########################################################################
# Copyright 2015, 2016, 2017 IoT.bzh
#
-# author: Loïc Collignon <loic.collignon@iot.bzh>
+# author: Romain Forlot <romain.forlot@iot.bzh>
#
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
@@ -18,18 +18,4 @@
CMAKE_MINIMUM_REQUIRED(VERSION 3.3)
-option(USE_LIBNFC "Enable or disable the 'libnfc' usage." ON)
-option(LIBNFC_POLL_ALL "Enable all modulation when polling." OFF)
-option(LIBNFC_POLL_NMT_ISO14443A "Enable ISO-14443A modulation when polling." ON)
-option(LIBNFC_POLL_NMT_ISOJEWEL "Enable ISO-JEWEL modulation when polling." OFF)
-option(LIBNFC_POLL_NMT_ISO14443B "Enable ISO-14443B modulation when polling." OFF)
-option(LIBNFC_POLL_NMT_ISO14443BI "Enable ISO-14443BI modulation when polling." OFF)
-option(LIBNFC_POLL_NMT_ISO14443B2SR "Enable ISO-14443B2SR modulation when polling." OFF)
-option(LIBNFC_POLL_NMT_ISO14443B2CT "Enable ISO-14443B2CT modulation when polling." OFF)
-option(LIBNFC_POLL_NMT_FELICA "Enable Felica modulation when polling." OFF)
-
include(${CMAKE_CURRENT_SOURCE_DIR}/conf.d/cmake/config.cmake)
-
-install(DIRECTORY htdocs/nfc DESTINATION htdocs)
-install(DIRECTORY etc DESTINATION ./)
-