aboutsummaryrefslogtreecommitdiffstats
path: root/binding/CMakeLists.txt
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-09-08 18:38:10 -0400
committerScott Murray <scott.murray@konsulko.com>2020-09-08 18:43:20 -0400
commit8afc720a98e4fdf4f5c1f10492e465927b8ffd86 (patch)
tree4f88905908c9cd67b2177652f1ce0a00486f610e /binding/CMakeLists.txt
parent4cdb281367813ffc12face0bbcba300fe6e7e2d3 (diff)
Changes: - Add null radio implementation that acts as the fallthrough default when the hardware implementations are not detected. - Tweaked the probing in the tef665x implementation to not return an error if the I2C node is not even present. This cleans up the logs on start up on most platforms. These changes include some minor whitespace consistency clean ups. - Added the run-by-default widget permission now that the binding should always work. This will ease testing, and potentially decrease app start up time. Bug-AGL: SPEC-3570 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I3c2e60ce7272d248ab87e3b79d6a334e17fe5531
Diffstat (limited to 'binding/CMakeLists.txt')
-rw-r--r--binding/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/binding/CMakeLists.txt b/binding/CMakeLists.txt
index 712e165..560dcaf 100644
--- a/binding/CMakeLists.txt
+++ b/binding/CMakeLists.txt
@@ -27,6 +27,7 @@ PROJECT_TARGET_ADD(radio-binding)
set(radio_SOURCES
radio-binding.c
radio_impl_kingfisher.c
+ radio_impl_null.c
radio_impl_rtlsdr.c
radio_impl_tef665x.c)