aboutsummaryrefslogtreecommitdiffstats
path: root/binding/CMakeLists.txt
diff options
context:
space:
mode:
authorScott Murray <scottm@ghidorah.spiteful.org>2018-05-15 08:42:33 -0400
committerScott Murray <scottm@ghidorah.spiteful.org>2018-05-15 11:50:14 -0400
commita714f867ef283ce6de606789aeda2fc17b644fac (patch)
tree97d974b3255d83a6556792753bc622207b313dd3 /binding/CMakeLists.txt
parent62518e9fdefa82a8d454e3dbcc28fd2efdc08fa0 (diff)
Always enable Kingfisher supporteel_5.0.3eel/5.0.35.0.3
Make Kingfisher support unconditional to move all platform detection to run-time. This fixes the issue of violating the application build workflow with the SDK. Additionally, the Kingfisher detection has been improved with an added check for the Si4689 device-tree node to differentiate from a regular M3ULCB, and the Kingfisher output has been fixed for recent BSP changes. Change-Id: I28e18a065385205aefec974079b0a9c2d31059b6 Signed-off-by: Scott Murray <scottm@ghidorah.spiteful.org>
Diffstat (limited to 'binding/CMakeLists.txt')
-rw-r--r--binding/CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/binding/CMakeLists.txt b/binding/CMakeLists.txt
index d0d23ed..321022a 100644
--- a/binding/CMakeLists.txt
+++ b/binding/CMakeLists.txt
@@ -24,13 +24,10 @@ PROJECT_TARGET_ADD(radio-binding)
set(radio_SOURCES
radio-binding.c
radio_output.c
+ radio_impl_kingfisher.c
radio_impl_rtlsdr.c
rtl_fm.c
convenience/convenience.c)
- if(HAVE_KINGFISHER)
- set(radio_SOURCES ${radio_SOURCES} radio_impl_kingfisher.c)
- add_definitions(-DHAVE_KINGFISHER)
- endif()
add_library(${TARGET_NAME} MODULE ${radio_SOURCES})