aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-01-03 00:51:50 -0500
committerScott Murray <scott.murray@konsulko.com>2023-01-03 00:57:12 -0500
commitdd23c157bdba1b25bbb50cdb99a60aa597735f43 (patch)
tree65c6f192bfc2f685e50d059d1e4ffb87fe7414f6 /meson.build
parente057ee1ea2af4ff1d8121a0857bd9fd63181fba2 (diff)
Repurpose into gRPC serviceneedlefish
Repurpose repository into a spiritual successor of the previous binding. The backend code is retained behind a new gRPC API defined in protos/radio.proto. The simpler synchronous gRPC API had been used for expediency, this may warrant revisiting to rework into an async or callback API based server instead. As well, authentication has been left until some consensus on an approach can be worked out. Bug-AGL: SPEC-4665 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I28b122ce6e0ecfc7504aa08b90394cb1b9e22976
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build35
1 files changed, 35 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..2277721
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,35 @@
+#
+# Copyright (C) 2022 Konsulko Group
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+project (
+ 'agl-service-radio',
+ ['c', 'cpp'],
+ version : '2.0.0',
+ license : 'Apache-2.0',
+ meson_version : '>= 0.46.0',
+ default_options :
+ [
+ 'warning_level=1',
+ 'buildtype=debugoptimized',
+ 'c_std=gnu17',
+ 'cpp_std=c++17'
+ ],
+)
+
+systemd_dep = dependency('systemd')
+
+subdir('src')
+subdir('systemd')