aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 1 insertions, 13 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3a692a6..328a786 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,5 @@
#
-# Copyright (c) 2017 TOYOTA MOTOR CORPORATION
-#
+# Copyright (c) 2017 TOYOTA MOTOR CORPORATION #
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
# You may obtain a copy of the License at
@@ -26,9 +25,6 @@ set(PROJECT_INCLUDEDIR ${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_INCLUDEDIR})
set(PROJECT_LIBDIR ${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR})
set(PROJECT_BINDINGDIR ${binding_install_dir})
-option (OTUPUT_DOXYGEN_DOC
- "output documentation" OFF )
-
# get pkgconfig
INCLUDE(FindPkgConfig)
link_libraries(-Wl,--as-needed -Wl,--gc-sections -Wl,--no-undefined)
@@ -38,11 +34,3 @@ add_definitions(-DDEBUGMODE)
add_subdirectory(src)
add_subdirectory(conf)
-
-if(OUTPUT_DOXGEN_DOC)
- find_package(Doxygen)
- add_custom_target (PluginRoutingAdapterALSADoku ALL
- COMMAND cd ${CMAKE_SOURCE_DIR}/doc/api-ref
- COMMAND doxygen ${CMAKE_SOURCE_DIR}/doc/api-ref/Doxyfile
- )
-endif()