aboutsummaryrefslogtreecommitdiffstats
path: root/sample/agl-service-steering-wheel_0.1.bb
diff options
context:
space:
mode:
authorzheng_wenlong <wenlong_zheng@nexty-ele.com>2019-04-04 09:03:27 +0900
committerzheng_wenlong <wenlong_zheng@nexty-ele.com>2019-04-04 09:04:27 +0900
commitc404f25dcaa4e622a0fe9179bc79393a468093d1 (patch)
treecb53edb66a21a4463cdea12082fbd5b77a057035 /sample/agl-service-steering-wheel_0.1.bb
parent1fed2c5a38fed8bc91bb6b8a08982303eb9c2e82 (diff)
Revert "Change steering to systemd service for ces2019"
This reverts commit 1fed2c5a38fed8bc91bb6b8a08982303eb9c2e82. Change-Id: Id83b437eef556b8d3fcd95503b9ff5b4d94bc7a5 Signed-off-by: zheng_wenlong <wenlong_zheng@nexty-ele.com>
Diffstat (limited to 'sample/agl-service-steering-wheel_0.1.bb')
-rw-r--r--sample/agl-service-steering-wheel_0.1.bb33
1 files changed, 2 insertions, 31 deletions
diff --git a/sample/agl-service-steering-wheel_0.1.bb b/sample/agl-service-steering-wheel_0.1.bb
index 8d57bbb..2391459 100644
--- a/sample/agl-service-steering-wheel_0.1.bb
+++ b/sample/agl-service-steering-wheel_0.1.bb
@@ -7,39 +7,10 @@ SECTION = "apps"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-steering-wheel;protocol=http;branch=master"
SRCREV = "8f6baa6092eb09919b71acbaaab9f013dcac599a"
-PN = "agl-service-steering-wheel"
+PN = "agl-service-steering-wheel"
S = "${WORKDIR}/git"
DEPENDS = "glib-2.0 af-binder"
-inherit cmake pkgconfig
+inherit cmake aglwgt
-do_install() {
- install -d ${D}/etc/
- install -m 0644 ${S}/conf/files/etc/steering_wheel.json ${D}/etc/
- install -m 0644 ${S}/conf/files/etc/steering_wheel_map.json ${D}/etc/
- install -m 0644 ${S}/conf/files/etc/gear_shift_para.json ${D}/etc/
-
- install -d ${D}/lib/systemd/system
- install -m 0644 ${S}/conf/files/lib/systemd/system/wheel.service ${D}/lib/systemd/system
- install -m 0644 ${S}/conf/files/lib/systemd/system/usbcan0.service ${D}/lib/systemd/system
- install -m 0644 ${S}/conf/files/lib/systemd/system/usbcan1.service ${D}/lib/systemd/system
-
- install -d ${D}/usr/bin
- install -m 755 ${S}/conf/files/usr/bin/candev.sh ${D}/usr/bin
- install -m 755 ${B}/bin/wheel-service ${D}/usr/bin
-
- install -d ${D}/etc/udev/rules.d/
- install -m 0644 ${S}/conf/files/etc/udev/rules.d/90-wheel.rules ${D}/etc/udev/rules.d/
-}
-
-FILES_${PN} += "/etc/steering_wheel.json \
- /etc/steering_wheel_map.json \
- /etc/gear_shift_para.json \
- /usr/bin/candev.sh \
- /usr/bin/wheel-service \
- /lib/systemd/system/wheel.service \
- /lib/systemd/system/usbcan0.service \
- /lib/systemd/system/usbcan1.service \
- /etc/udev/rule.d/90-wheel.rules \
- "