summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 2 insertions, 16 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4c343b3..3fe99ce 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,20 +14,6 @@
# limitations under the License.
#
-project(af-steering-wheel-binding C)
-
-cmake_minimum_required(VERSION 2.8)
-
-include(GNUInstallDirs)
-
-set(PROJECT_NAME "af-steering-wheel-binding")
-set(PROJECT_PRETTY_NAME "af binding for steering wheel")
-set(PROJECT_DESCRIPTION "Binding for handling Vehicle signalisation of steering wheel")
-set(PROJECT_VERSION "1.0")
-
-#set(CMAKE_BUILD_TYPE Debug)
-set(CMAKE_BUILD_TYPE Release)
-
-add_subdirectory(src)
-
+CMAKE_MINIMUM_REQUIRED(VERSION 3.3)
+include(${CMAKE_CURRENT_SOURCE_DIR}/conf.d/cmake/config.cmake)