aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorYordan Dimitrov <y.dimitrov.14@gmail.com>2018-08-15 15:54:37 +0300
committerYordan Dimitrov <y.dimitrov.14@gmail.com>2018-08-17 11:28:31 +0300
commit4c13256dce57776b6ce5ae5e2ce4fff52f6e2ab8 (patch)
tree07b12f7562ece1f336e3cbcd9ac59cb3bfbe7db5 /CMakeLists.txt
parent183cb22a76b3c1d0d77757512009fda8269ff3d6 (diff)
Importing agl-service-taskmanager code
The service queries /proc for system statistics data and collects data for all processes currently running on the system. The data for each consists of process name, process ID, user, system CPU usage, user CPU usage, memory and state. The data is then converted to JSON and sent to the requesting app. v1 - removed trailing whitespaces - added description in the README file - removed URL from config.cmake v2 - added project URL to config.cmake Change-Id: I7670c239191ee9b7333d5a383f1b2fcf6bc774c1 Signed-off-by: Yordan Dimitrov <y.dimitrov.14@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..fdecd32
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,4 @@
+CMAKE_MINIMUM_REQUIRED(VERSION 3.3)
+
+include(${CMAKE_CURRENT_SOURCE_DIR}/conf.d/cmake/config.cmake)
+