aboutsummaryrefslogtreecommitdiffstats
path: root/binding/slimamp/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Jahnke <tobias.jahnke@microchip.com>2019-08-09 14:12:09 +0200
committerTobias Jahnke <tobias.jahnke@microchip.com>2019-08-12 08:52:11 +0200
commitfa46d3cd2c0166d064a720bd5e621b11751a9977 (patch)
tree17f954cd224f80557d615cb0db537c962e298c3c /binding/slimamp/CMakeLists.txt
parent114741ed6314cf042460804effdab399936585cc (diff)
unicens-controller: insert initial code of service
Bug-AGL: SPEC-2738 - adds service widget to control microphone mode, amplifier and slimamp master volume Signed-off-by: Tobias Jahnke <tobias.jahnke@microchip.com> Change-Id: I2463b0351c740c738e35185997d926a602bb2489 Signed-off-by: Tobias Jahnke <tobias.jahnke@microchip.com>
Diffstat (limited to 'binding/slimamp/CMakeLists.txt')
-rw-r--r--binding/slimamp/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/binding/slimamp/CMakeLists.txt b/binding/slimamp/CMakeLists.txt
new file mode 100644
index 0000000..f2a7d66
--- /dev/null
+++ b/binding/slimamp/CMakeLists.txt
@@ -0,0 +1,32 @@
+################################################################################
+# Copyright 2019 Microchip Technology Inc. and its subsidiaries
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+################################################################################
+
+# Add target to project dependency list
+PROJECT_TARGET_ADD(ucs-slimamp)
+
+# Define targets source files
+ADD_LIBRARY(${TARGET_NAME} STATIC slimamp.c)
+
+ # Expose Library Properties
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES OUTPUT_NAME slimamp)
+
+ # Library dependencies from PKG_REQUIRED_LIST
+ TARGET_LINK_LIBRARIES(${TARGET_NAME} ${link_libraries})
+
+ # Define properties to expose when others use this target
+ TARGET_INCLUDE_DIRECTORIES(${TARGET_NAME} PUBLIC
+ ${CMAKE_CURRENT_SOURCE_DIR}/../wrap-unicens
+ )