aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMalik Talha <talhamalik727x@gmail.com>2023-09-14 22:41:26 +0500
committerMalik Talha <talhamalik727x@gmail.com>2023-09-25 00:40:38 +0500
commita10c988b5480ca5b937a2793b450cfa01f569d76 (patch)
tree23c032557a36afd671c7b7db9d6dd843253ae835 /setup.py
parent3e300cdc7fff19e5f338b282266444061f74506e (diff)
Add gRPC-based voice agent service for AGL
Introducing a gRPC-based voice agent service for Automotive Grade Linux (AGL) that leverages GStreamer, Vosk, Snips, and RASA. It seamlessly processes user voice commands, converting spoken words to text, extracting intents, and performing actions via the Kuksa interface (WIP). Bug-AGL: SPEC-4906 Signed-off-by: Malik Talha <talhamalik727x@gmail.com> Change-Id: I47e61c66149c67bb97fecc745e4c3afd79f447a5
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py35
1 files changed, 35 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..9c608e7
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,35 @@
+from setuptools import setup, find_packages
+
+packages = [p for p in find_packages()
+ if "tests" not in p and "debug" not in p]
+
+setup(
+ name="agl_service_voiceagent",
+ version="0.2.0",
+ description="A gRPC-based voice agent service designed for Automotive Grade Linux (AGL). This service leverages GStreamer, Vosk, Snips, and RASA to seamlessly process user voice commands. It converts spoken words into text, extracts intents from these commands, and performs actions through the Kuksa interface.",
+ url="https://github.com/malik727/agl-service-voiceagent",
+ author="Malik Talha",
+ author_email="talhamalik727x@gmail.com",
+ install_requires=[
+ "kuksa-client==0.4.0",
+ "grpcio==1.45.0",
+ "grpcio-tools==1.45.0",
+ "vosk==0.3.42",
+ "PyGObject==3.42.0",
+ "rasa==3.6.4",
+ "numpy==1.22.3",
+ "tensorflow==2.12.0",
+ "tensorboard==2.12.0",
+ "keras==2.12.0",
+ ],
+ license="Apache-2.0",
+ python_requires=">=3.9",
+ packages=packages,
+ package_data={'agl_service_voiceagent': ['config.ini']},
+ include_package_data=True,
+ entry_points={
+ "console_scripts": [
+ "voiceagent-service=agl_service_voiceagent.service:main"
+ ],
+ },
+) \ No newline at end of file