aboutsummaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorEdi Feschiyan <edi.feschiyan@konsulko.com>2019-04-25 22:02:05 +0300
committerEdi Feschiyan <edi.feschiyan@konsulko.com>2019-06-17 23:56:41 +0300
commit960e590d60f722b8dc4bb8d4d68462fc722572de (patch)
tree5e203f716cb00dbb332dbb8ff88e5c97051d6019 /test/CMakeLists.txt
parent51b1c8317c918cf0abad847f8aa50583c540b4ba (diff)
Adding weather service tests
Bug-AGL: SPEC-2529 Change-Id: I45e875c7ee9b0b77b2d2fb6c94e4bbcf78c1e65d Signed-off-by: Edi Feschiyan <edi.feschiyan@konsulko.com>
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
new file mode 100644
index 0000000..75bcf58
--- /dev/null
+++ b/test/CMakeLists.txt
@@ -0,0 +1,28 @@
+###########################################################################
+# Copyright 2019 Konsulko Group
+#
+# author:Stoyan Bogdanov <stoyan.bogdanov@konsulko.com>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+
+# Include any directory not starting with _
+# -----------------------------------------------------
+PROJECT_SUBDIRS_ADD(${PROJECT_SRC_DIR_PATTERN})
+
+ADD_TEST(NAME AGL_SERVICE_GPS_TESTS
+ WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
+ COMMAND afb-test.sh "${CMAKE_BINARY_DIR}/package" "${CMAKE_BINARY_DIR}/package-test" SERVICE
+ )
+