aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2020-02-21 17:20:39 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2020-02-21 17:58:59 +0100
commit04be11d71be97fe91591cee18077bd244788a7a0 (patch)
tree9aac0b6e62f3e4ea085dce8fcb40c44bc32bfa18 /CMakeLists.txt
parentde70b5f128a2b993e88020ff717e763a53e385f7 (diff)
Fix build
The previous commit broke the normal creation of the widget. This commit partly reverse it. A cleaner solution should be found. Bug-AGL: SPEC-2049 Change-Id: I9c0b6be129fe4eb453dbad4bcdbcb3f891690869 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt21
1 files changed, 19 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index feaa536..8a69a43 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,7 +14,24 @@
# limitations under the License.
#
+cmake_minimum_required(VERSION 2.8)
-CMAKE_MINIMUM_REQUIRED(VERSION 3.3)
+project(WindowManagerTMC)
-include(${CMAKE_CURRENT_SOURCE_DIR}/conf.d/cmake/config.cmake)
+set(PACKAGE_VERSION_MAJOR 0)
+set(PACKAGE_VERSION_MINOR 0)
+set(PACKAGE_VERSION_REVISION 1)
+set(PACKAGE_VERSION "${PACKAGE_VERSION_MAJOR}.${PACKAGE_VERSION_MINOR}.${PACKAGE_VERSION_REVISION}")
+
+find_package(PkgConfig REQUIRED)
+include(GNUInstallDirs)
+
+set(SANITIZER_MODE "none" CACHE STRING "Build using a specific sanitizer (e.g. 'address', 'thread', 'leak', 'undefined'), depends on compiler; default none")
+
+set(LINK_LIBCXX OFF CACHE BOOL "Link against LLVMs libc++")
+
+# Add PolicyManager as plugin
+set(PLUGIN_PM policy_manager)
+add_subdirectory(${PLUGIN_PM})
+
+add_subdirectory(src)