aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorYuta Doi <yuta-d@witz-inc.co.jp>2018-07-09 17:23:31 +0900
committerYuta Doi <yuta-d@witz-inc.co.jp>2018-07-12 09:24:56 +0900
commit99b6f4d2fcd421d3a760a88a67e511fb6fc98068 (patch)
tree12c17f502e37b6742ead94e2d5bba07822300328 /CMakeLists.txt
parent8ab10aaafc6fb3dc7bbad755dce9b4bdaa41f287 (diff)
Add PolicyManager as plugin
PolicyManager decides next layout by using occured event and current state based on the policy table. And PolicyManager is plugin for WindowManager. Therefore the OEMs can replace it. This patch provides PolicyManager I/F as reference implementation and does not have policy table. Therefore PolicyManager updates each layers to draw the applications in normal.full area in accordance with just like activate/deactivate request. [APIs of PolicyManager class] - int initialize(void) Initialize PolicyManger. input: none output: 0(success), -1(error) - void registerCallback(CallbackTable callback_table) Register callback functions. input: the pointers of callback handlers output: none "CallbackTable" type is as follows: typedef struct { Handler onStateTransitioned; Handler onError; } CallbackTable; "Handler" type is as follows: using Handler = std::function<void(json_object *)>; - int setInputEventData(json_object *json_in) Set input event data for the policy table. input: input event data as json_object output: 0(success), -1(error) - int executeStateTransition(void) Execute state transition by using set input event data. input: none output: 0(success), -1(error) - void undoState(void) Undo state only once per once state transition. input: none output: none [Callbacks of PolicyManager class] - void onStateTransitioned(json_object *json_out) When state transition succeeds, this callback is called. The argument json_out has the state after transition. - void onError(json_object *json_out) When state transition fails, this callback is called. The argument json_out has the error information like message, inputed event datas and etc.. Bug-AGL: SPEC-1537 Change-Id: I44b771d4145078bf3ea05e26165bb9c1a03b10c3 Signed-off-by: Yuta Doi <yuta-d@witz-inc.co.jp>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4ed6d6d..92ee691 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -79,4 +79,16 @@ set(SANITIZER_MODE "none" CACHE STRING "Build using a specific sanitizer (e.g. '
set(LINK_LIBCXX OFF CACHE BOOL "Link against LLVMs libc++")
+# Set name of PolicyManager and STM
+set(PLUGIN_PM policy_manager)
+set(USE_STM_NAME stub)
+
+# Add STM
+add_subdirectory(src/${PLUGIN_PM}/stm/${USE_STM_NAME}/src)
+include_directories(src/${PLUGIN_PM}/stm/${USE_STM_NAME}/src)
+
+# Add PolicyManager as plugin
+add_subdirectory(src/${PLUGIN_PM})
+include_directories(src/${PLUGIN_PM})
+
add_subdirectory(src)