aboutsummaryrefslogtreecommitdiffstats
path: root/src/policy_manager/stm/zipc/src/CMakeLists.txt
diff options
context:
space:
mode:
authorYuta Doi <yuta-d@witz-inc.co.jp>2018-07-11 16:21:37 +0900
committerYuta Doi <yuta-d@witz-inc.co.jp>2018-07-12 00:27:30 +0000
commit67f414f67ee22ddf40003d1be3fa1d0cb13deb8f (patch)
tree407f01c2af124c97f38d79403b808828b6ea527f /src/policy_manager/stm/zipc/src/CMakeLists.txt
parent99b6f4d2fcd421d3a760a88a67e511fb6fc98068 (diff)
Add policy table generated by ZIPC for EXAMPLEflounder_5.99.2flounder/5.99.25.99.2
To PolicyManager, add the source code of policy table which is generated by ZIPC for EXAMPLE. If use this example, please comment out line 84 and uncomment line 85 in CMakeLists.txt as follows: #set(USE_STM_NAME stub) set(USE_STM_NAME zipc) If try to show split layout, please rename from roles.db.split to roles.db in src/policy_manager/db/. Bug-AGL: SPEC-1537 Change-Id: I4b35f148313e0c5a12c59ed1c2f8eb6fbcf3ea6b Signed-off-by: Yuta Doi <yuta-d@witz-inc.co.jp>
Diffstat (limited to 'src/policy_manager/stm/zipc/src/CMakeLists.txt')
-rw-r--r--src/policy_manager/stm/zipc/src/CMakeLists.txt83
1 files changed, 83 insertions, 0 deletions
diff --git a/src/policy_manager/stm/zipc/src/CMakeLists.txt b/src/policy_manager/stm/zipc/src/CMakeLists.txt
new file mode 100644
index 0000000..27ca92b
--- /dev/null
+++ b/src/policy_manager/stm/zipc/src/CMakeLists.txt
@@ -0,0 +1,83 @@
+#
+# Copyright (c) 2017 TOYOTA MOTOR CORPORATION
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+include(FindPkgConfig)
+
+# We do not want a prefix for our module
+set(CMAKE_SHARED_MODULE_PREFIX "")
+
+set(TARGETS_STM libstm)
+
+set(ST_DIR StateTransitionor)
+set(ST_DIR_CMN Common)
+set(ST_DIR_AL ${ST_DIR}/AppsLayer)
+set(ST_DIR_HS ${ST_DIR}/HomeScreenLayer)
+set(ST_DIR_NHS ${ST_DIR}/NearHomeScreen)
+set(ST_DIR_OS ${ST_DIR}/OnScreenlayer)
+set(ST_DIR_RL ${ST_DIR}/RestrictionLayer)
+set(ST_DIR_RM ${ST_DIR}/RestrictionMode)
+
+add_library(${TARGETS_STM} MODULE
+ ${ST_DIR}/ZST_StateTransitionor_func.c
+ ${ST_DIR}/ZST_StateTransitionor_var.c
+ ${ST_DIR_AL}/ZAPL_AppsLayer.c
+ ${ST_DIR_AL}/ZAPL_Apps_func.c
+ ${ST_DIR_HS}/ZHSL_HomeScreen.c
+ ${ST_DIR_HS}/ZHSL_HomeScreen_func.c
+ ${ST_DIR_NHS}/ZNHL_NearHomescreen.c
+ ${ST_DIR_NHS}/ZNHL_NearHomeScreen_func.c
+ ${ST_DIR_OS}/ZOSL_OslMain.c
+ ${ST_DIR_OS}/ZOSL_OnScreen_func.c
+ ${ST_DIR_RL}/ZREL_RelMain.c
+ ${ST_DIR_RL}/ZREL_Restriction_func.c
+ ${ST_DIR_RM}/ZREM_RestrictionMode.c
+ ${ST_DIR_RM}/ZREM_RestrictionMode_func.c
+)
+
+target_include_directories(${TARGETS_STM}
+ PRIVATE
+ ./include
+ ./${ST_DIR}
+ ./${ST_DIR_AL}
+ ./${ST_DIR_HS}
+ ./${ST_DIR_NHS}
+ ./${ST_DIR_OS}
+ ./${ST_DIR_RL}
+ ./${ST_DIR_RM}
+ ./${ST_DIR_CMN}
+)
+
+target_compile_definitions(${TARGETS_STM}
+ PRIVATE
+ _GNU_SOURCE
+)
+
+target_compile_options(${TARGETS_STM}
+ PRIVATE
+ -Wall -Wextra -Wno-unused-parameter -Wno-comment)
+
+set_target_properties(${TARGETS_STM}
+ PROPERTIES
+ C_EXTENSIONS OFF
+ C_STANDARD 99
+ C_STANDARD_REQUIRED ON
+)
+
+install(
+ TARGETS ${TARGET_STM}
+ DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ COMPONENT "runtime"
+)