aboutsummaryrefslogtreecommitdiffstats
path: root/xds-service/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'xds-service/CMakeLists.txt')
-rw-r--r--xds-service/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/xds-service/CMakeLists.txt b/xds-service/CMakeLists.txt
new file mode 100644
index 0000000..9ce0b81
--- /dev/null
+++ b/xds-service/CMakeLists.txt
@@ -0,0 +1,42 @@
+###########################################################################
+# Copyright 2018 IoT.bzh
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+# Add target to project dependency list
+PROJECT_TARGET_ADD(xds-service)
+
+ # Define project Targets
+ file(GLOB sourcelist "*.c")
+
+ # Define project Targets
+ ADD_LIBRARY(${TARGET_NAME} MODULE ${sourcelist})
+
+ target_compile_options(${TARGET_NAME}
+ PUBLIC -Wno-unused-variable
+ )
+
+
+ # Binder exposes a unique public entry point
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ PREFIX "afb-"
+ LABELS "BINDINGV2"
+ LINK_FLAGS ${BINDINGS_LINK_FLAG}
+ OUTPUT_NAME ${TARGET_NAME}
+ )
+
+ TARGET_LINK_LIBRARIES(${TARGET_NAME}
+ afb-helpers
+ ${link_libraries}
+ )