summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-03-07 15:56:17 -0500
committerScott Murray <scott.murray@konsulko.com>2022-03-07 16:12:00 -0500
commit30c275c5c87b9d4f0bc3b0e0e3175775d3738319 (patch)
tree715a4d5c79cee50b763e9253cc454b43fb9efea6 /CMakeLists.txt
parent714ad7e26b9860360fb8098613f8b4887d851e12 (diff)
Changes: - Remove the autobuild scripts and config.xml used by the app framework widget build. - Update the CMake files to just build a "camera-gstreamer" binary and install it into /usr/bin by default. - Remove the code in main.cpp that handled reading the WebSocket command-line arguments and passing them to binding related code. - Added installation of a minimal .desktop file to work with the new applaunchd. Bug-AGL: SPEC-4284 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I87816800c117a243a107eecb8895f07d6c90f23a
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 50cee76..c21c5bf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,5 @@
# Copyright 2021 Collabora, Ltd.
+# Copyright 2022 Konsulko Group
#
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
@@ -15,5 +16,4 @@
CMAKE_MINIMUM_REQUIRED(VERSION 3.3)
-project(camera-gstreamer)
-include(${CMAKE_CURRENT_SOURCE_DIR}/conf.d/cmake/config.cmake)
+add_subdirectory(app)