aboutsummaryrefslogtreecommitdiffstats
path: root/low-can-binding/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2017-07-13 18:51:20 +0200
committerRomain Forlot <romain.forlot@iot.bzh>2017-07-21 12:02:11 +0200
commit2408a177e8260dcda266df9993e6acd528bebbbc (patch)
tree32fbc74e96659d701496a3687ef9c0496dd4fd07 /low-can-binding/CMakeLists.txt
parent0dc8b87f5d8a03183c1b947640f6315545e4207b (diff)
Be able to write raw frame & encode value to sent
Check whether the argument is a raw frame or a Signal + Value to encode then send. 1 new class to handle encoding part of a value as well as a new method for can_signal_t which return index of a map from its value. Change-Id: I288d2aeec28ce74c9ca35750db18557c9251e1df Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'low-can-binding/CMakeLists.txt')
-rw-r--r--low-can-binding/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/low-can-binding/CMakeLists.txt b/low-can-binding/CMakeLists.txt
index fd68e6c..44ae9ef 100644
--- a/low-can-binding/CMakeLists.txt
+++ b/low-can-binding/CMakeLists.txt
@@ -34,6 +34,7 @@ PROJECT_TARGET_ADD(low-can)
can/can-message.cpp
can/can-signals.cpp
can/can-decoder.cpp
+ can/can-encoder.cpp
diagnostic/diagnostic-message.cpp
diagnostic/diagnostic-manager.cpp
diagnostic/active-diagnostic-request.cpp