aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLoïc Collignon <loic.collignon@iot.bzh>2018-07-02 15:38:32 +0200
committerLoïc Collignon <loic.collignon@iot.bzh>2018-07-10 19:21:41 +0200
commitc56b75f6511015edb4417df81d97aa6181e5480e (patch)
tree81fc62d2d341b518b1f9639c3eb862b67c4252c1 /CMakeLists.txt
parentaf3fc263d66cb981e2ca159109d8c2edf1b89e09 (diff)
Allow to build and run on native linux host
Make libhomescreen and libmanager dependencies optional so that you can build, run and debug on a native linux host, to allow faster development. Change-Id: Ice0b7e196e9a88dc7f0f8e9894eb9091c6ba566e Signed-off-by: Loïc Collignon <loic.collignon@iot.bzh>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 806ae35..37683ee 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,6 +21,5 @@ CMAKE_MINIMUM_REQUIRED(VERSION 3.3)
set(AFB_HELPERS_QTWSCLIENT ON CACHE BOOL "enable Qt's WebSocket client" FORCE)
add_definitions(-DUSE_API_DYN)
-#add_definitions(-DAFB_BINDING_WANT_DYNAPI)
include(${CMAKE_CURRENT_SOURCE_DIR}/conf.d/cmake/config.cmake)