aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2020-05-15 18:52:41 +0300
committerMarius Vlad <marius.vlad@collabora.com>2020-06-12 15:19:22 +0300
commitfbdf8275a405ea4eca7be070c352280e8fde591c (patch)
treed2a94635e1f7735f2c090c445fae9a14b4cce907 /CMakeLists.txt
parent19a329ee308eb4de36dfc1e68d6c5098b57186fd (diff)
Remove windowmanager dependssandbox/mvlad/agl-compositor
Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9af2455..0fd1f5a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,7 +26,6 @@ pkg_check_modules(JSON REQUIRED json-c)
pkg_check_modules(QT5_WIDGETS REQUIRED Qt5Widgets)
pkg_check_modules(QT5_NETWORK REQUIRED Qt5Network)
pkg_check_modules(LIBQTAPPFW REQUIRED qtappfw-navigation)
-pkg_check_modules(QLIBWIN REQUIRED qlibwindowmanager)
pkg_check_modules(LIBHS REQUIRED libhomescreen)
@@ -38,7 +37,7 @@ qt5_wrap_cpp(yelp_client_SRC MainApp.h InfoPanelLabel.h ClickableLabel.h Keyboar
QT5_ADD_RESOURCES(yelp_client_QRC yelp-client.qrc)
add_executable( yelp-client main.cpp MainApp.cpp InfoPanel.cpp InfoPanelLabel.cpp Keyboard.cpp yelp-client.qrc ${yelp_client_SRC} ${yelp_client_QRC})
#target_link_libraries( yelp-client binderclient )
-target_link_libraries( yelp-client ${LIBQTAPPFW_LIBRARIES} ${JSON_LIBRARIES} ${QLIBWIN_LIBRARIES} ${LIBHS_LIBRARIES} )
+target_link_libraries( yelp-client ${LIBQTAPPFW_LIBRARIES} ${JSON_LIBRARIES} ${LIBHS_LIBRARIES} )
qt5_use_modules(yelp-client Core Widgets Network)
install (TARGETS yelp-client DESTINATION bin)